summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyril Andreatta2016-07-14 23:47:54 +0200
committerCyril Andreatta2016-07-14 23:47:54 +0200
commit89dee8f1672a5dc2534a6eef5eb4c44005c32a8d (patch)
treedb4c1908b30b5b8e4f5161253397d371acd64883
downloadaur-script-communicator-git.tar.gz
Initial Commit
Git based package for script-communicator. Description ScriptCommunicator is a scriptable cross-platform data terminal which supports serial port (RS232, USB to serial), UDP, TCP client/server (network proxy support for TCP clients), SPI master (cheetah SPI)
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD57
-rw-r--r--script-communicator.desktop11
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16507bc7a601
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = script-communicator-git
+pkgdesc = ScriptCommunicator is a scriptable cross-platform data terminal with support for serial port (RS232, USB to serial), UDP, TCP client/server (network proxy support for TCP clients), SPI master (cheetah SPI)
+pkgver = 04.14.191
+pkgrel = 1
+url = https://github.com/szieke/ScriptCommunicator_serial-terminal
+arch = i386
+arch = x86_64
+license = LGPL
+makedepends = git
+makedepends = qt5-tools
+depends = qt5-base
+depends = qt5-serialport
+depends = qt5-script
+provides = script-communicator
+conflicts = script-communicator
+source = git://github.com/szieke/ScriptCommunicator_serial-terminal
+source = script-communicator.desktop
+md5sums = SKIP
+md5sums = 2178766b1e5dcccffe29d666625d111a
+pkgname = script-communicator-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9a1d6cf3705
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Cyril Andreatta arch@andreatta.ch
+# Thanx to Stefan Zieker <s.zieker@gmx.net> and Jake <ja.ke@posteo.de>
+
+pkgname=script-communicator-git
+_pkgname_generic=${pkgname%-git}
+_name=ScriptCommunicator
+_fullname=ScriptCommunicator_serial-terminal
+_path=$_fullname/$_name
+pkgver=04.14.193
+pkgrel=1
+pkgdesc="ScriptCommunicator is a scriptable cross-platform data terminal with support for serial port (RS232, USB to serial), UDP, TCP client/server (network proxy support for TCP clients), SPI master (cheetah SPI)
+"
+arch=('i386' 'x86_64')
+url="https://github.com/szieke/ScriptCommunicator_serial-terminal"
+license=('LGPL')
+groups=()
+depends=('qt5-base' 'qt5-serialport' 'qt5-script')
+makedepends=('git' 'qt5-tools')
+provides=("$_pkgname_generic")
+conflicts=("$_pkgname_generic")
+replaces=()
+backup=()
+options=(!strip debug)
+source=("git://github.com/szieke/ScriptCommunicator_serial-terminal"
+ "$_pkgname_generic.desktop")
+noextract=()
+md5sums=(SKIP
+ '2178766b1e5dcccffe29d666625d111a')
+
+pkgver() {
+ cd $_fullname
+ printf "$(grep 'VERSION = ' ScriptCommunicator/mainwindow.cpp | cut -d'"' -f2
+ ).$(git rev-list --count master)"
+}
+
+build() {
+ cd $_path
+ qmake
+ make
+}
+
+package() {
+ install -Dm644 "$_pkgname_generic.desktop" "$pkgdir/usr/share/applications/$pkgname_generic.desktop"
+
+ install -Dm644 "$_path/images/main_32x32.png" "$pkgname/usr/share/pixmaps/$_pkgname_generic.png"
+
+ mkdir -p "$pkgdir/opt/$pkgname"
+ install -Dm755 "$_path/ScriptCommunicator" "$pkgdir/opt/$pkgname/$_pkgname_generic"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/$pkgname/$_pkgname_generic" "$pkgdir/usr/bin/$_pkgname_generic"
+
+ cd $_path
+ cp -r templates exampleScripts documentation "$pkgdir/opt/$pkgname/"
+
+ make INSTALL_ROOT="/usr/bin/script-communicator" install
+}
diff --git a/script-communicator.desktop b/script-communicator.desktop
new file mode 100644
index 000000000000..8bdeb6917203
--- /dev/null
+++ b/script-communicator.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=ScriptCommunicator
+Comment=Scriptable terminal with Serial/TCP/UDP/SPI/CAN support
+Exec=script-communicator
+Icon=script-communicator
+Path=/usr/bin
+Terminal=false
+StartupNotify=false
+Categories=Development