summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Kozdrój2021-02-12 21:26:32 +0100
committerRafał Kozdrój2021-02-12 21:26:34 +0100
commit9c8186c69213c5fa11b0aea50fefcb8bb344e34f (patch)
treed4c67871533314298d8c2b4b98c2032f71849db4
downloadaur-sdl-git.tar.gz
SDL-git 1.2.15.r336.08d4c52c-1
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD40
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6da3e672cb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = sdl-git
+ pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard
+ pkgver = 1.2.15.r336.08d4c52c
+ pkgrel = 1
+ url = https://www.libsdl.org
+ arch = x86_64
+ license = LGPL
+ makedepends = alsa-lib
+ makedepends = mesa
+ makedepends = libpulse
+ makedepends = glu
+ makedepends = git
+ depends = glibc
+ depends = libxext
+ depends = libxrender
+ depends = libx11
+ optdepends = alsa-lib: ALSA audio driver
+ optdepends = libpulse: PulseAudio audio driver
+ provides = sdl=1.2.15.r336.08d4c52c
+ conflicts = sdl
+ options = staticlibs
+ source = git+https://github.com/libsdl-org/SDL-1.2.git
+ md5sums = SKIP
+
+pkgname = sdl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d257381f39d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Rafał Kozdrój <kozeid2+aur@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+
+_pkgname=sdl
+pkgname=$_pkgname-git
+pkgver=1.2.15.r336.08d4c52c
+pkgrel=1
+pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard"
+arch=('x86_64')
+url="https://www.libsdl.org"
+license=('LGPL')
+depends=('glibc' 'libxext' 'libxrender' 'libx11')
+makedepends=('alsa-lib' 'mesa' 'libpulse' 'glu' 'git')
+optdepends=('alsa-lib: ALSA audio driver'
+ 'libpulse: PulseAudio audio driver')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+options=('staticlibs')
+source=("git+https://github.com/libsdl-org/SDL-1.2.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "SDL-1.2"
+ git describe --long --tags | sed 's/^release-//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+build() {
+ cd "SDL-1.2"
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-nasm --enable-alsa \
+ --with-x --disable-rpath --disable-static
+ make
+}
+
+package() {
+ cd "SDL-1.2"
+ make DESTDIR="$pkgdir/" install
+}