summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2018-11-10 01:12:06 -0500
committerVincent Grande2018-11-10 01:12:06 -0500
commita318dbfc591f8baee3989d6edaae7c8fd54ff79f (patch)
tree956dd7128094d7555c3dc63a0bf5e6d0529671f1
parentcbcf28f1878370dbd2e4211597a8c734e0768654 (diff)
downloadaur-a318dbfc591f8baee3989d6edaae7c8fd54ff79f.tar.gz
matched with official repo PKGBUILD
-rw-r--r--.SRCINFO24
-rwxr-xr-x[-rw-r--r--]PKGBUILD70
2 files changed, 52 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1bd128432fe..b61bbf3a5c8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,36 @@
pkgbase = sdl2-hg
- pkgdesc = A library for portable low-level access to video, audio and input (Version 2, development version)
- pkgver = 2.0.5.r423.2653833db94e
+ pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2)
+ pkgver = 2.0.9.r22.80f861112154
pkgrel = 1
- url = http://www.libsdl.org
- arch = i686
+ url = https://www.libsdl.org
arch = x86_64
- license = ZLIB
- makedepends = mercurial
+ license = MIT
makedepends = alsa-lib
makedepends = mesa
makedepends = libpulse
- makedepends = libxinerama
- makedepends = libxkbcommon
makedepends = libxrandr
+ makedepends = libxinerama
makedepends = wayland
+ makedepends = libxkbcommon
makedepends = wayland-protocols
makedepends = ibus
makedepends = fcitx
makedepends = libxss
- depends = sh
+ makedepends = cmake
+ depends = glibc
depends = libxext
depends = libxrender
depends = libx11
depends = libgl
depends = libxcursor
- depends = libsamplerate
+ depends = libibus
optdepends = alsa-lib: ALSA audio driver
optdepends = libpulse: PulseAudio audio driver
provides = sdl2
conflicts = sdl2
- source = sdl2::hg+http://hg.libsdl.org/SDL
- md5sums = SKIP
+ source = hg+http://hg.libsdl.org/SDL#branch=default
+ validpgpkeys = SKIP
+ sha512sums = SKIP
pkgname = sdl2-hg
diff --git a/PKGBUILD b/PKGBUILD
index 2823a8c6cad6..059fd8bf6fd5 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,64 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-# Contributor: Daniel Kirchner <daniel at ekpyron dot rog>
-# Contributor: Gustavo Alvarez <sl1pkn07 at gmail dot com>
-# Contributor: Chase Geigle <sky at skystrife dot com>
-# Contributor: Axper Jan <483ken at gmail dot com>
+# $Id$
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
pkgname=sdl2-hg
-pkgver=2.0.5.r423.2653833db94e
+pkgver=2.0.9.r22.80f861112154
pkgrel=1
-pkgdesc="A library for portable low-level access to video, audio and input (Version 2, development version)"
-arch=('i686' 'x86_64')
-url="http://www.libsdl.org"
-license=('ZLIB')
-provides=('sdl2')
-conflicts=('sdl2')
-depends=('sh' 'libxext' 'libxrender' 'libx11' 'libgl' 'libxcursor' 'libsamplerate')
-makedepends=('mercurial' 'alsa-lib' 'mesa' 'libpulse' 'libxinerama' 'libxkbcommon'
- 'libxrandr' 'wayland' 'wayland-protocols' 'ibus' 'fcitx' 'libxss')
+pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2)"
+arch=('x86_64')
+url="https://www.libsdl.org"
+license=('MIT')
+depends=('glibc' 'libxext' 'libxrender' 'libx11' 'libgl' 'libxcursor' 'libibus')
+makedepends=('alsa-lib' 'mesa' 'libpulse' 'libxrandr' 'libxinerama' 'wayland' 'libxkbcommon'
+ 'wayland-protocols' 'ibus' 'fcitx' 'libxss' 'cmake')
optdepends=('alsa-lib: ALSA audio driver'
'libpulse: PulseAudio audio driver')
-source=(sdl2::"hg+http://hg.libsdl.org/SDL")
-md5sums=('SKIP')
+source=("hg+http://hg.libsdl.org/SDL#branch=default")
+provides=(sdl2)
+conflicts=(sdl2)
+sha512sums=('SKIP')
+validpgpkeys=('SKIP') # Sam Lantinga
pkgver() {
- cd sdl2
+ cd SDL
_tag=$(hg tags -q | sort -r | grep release- | head -n1)
_commits=$(hg log --template "{node}\n" -r $_tag:tip | wc -l)
echo "${_tag/release-}.r$_commits.$(hg identify -i)"
}
prepare() {
- # reset build folder
+ cd SDL
+
rm -rf build
mkdir build
}
build() {
- cd build
-
- ../sdl2/configure --prefix=/usr \
- --enable-sdl-dlopen \
- --disable-arts --disable-esd --disable-nas \
- --enable-alsa --enable-pulseaudio-shared \
- --enable-video-wayland \
- --enable-ibus --enable-fcitx \
- --disable-rpath
+ cd SDL/build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DSDL_STATIC=OFF \
+ -DSDL_DLOPEN=ON \
+ -DARTS=OFF \
+ -DESD=OFF \
+ -DNAS=OFF \
+ -DALSA=ON \
+ -DPULSEAUDIO_SHARED=ON \
+ -DVIDEO_WAYLAND=ON \
+ -DRPATH=OFF \
+ -DCLOCK_GETTIME=ON \
+ -DJACK_SHARED=ON
make
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ cd SDL/build
+
+ make DESTDIR="${pkgdir}" install
- install -Dm644 sdl2/COPYING.txt "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ sed -i "s/libSDL2\.a/libSDL2main.a/g" "$pkgdir"/usr/lib/cmake/SDL2/SDL2Targets-noconfig.cmake
+
+ install -Dm644 ../COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+# vim: ts=2 sw=2 et: