summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2017-04-24 22:10:10 +0200
committerCarsten Teibes2017-04-24 22:10:10 +0200
commitcbcf28f1878370dbd2e4211597a8c734e0768654 (patch)
tree332a2edc4630812e511a415382ef61e42cfd7155
parent9c5da73cb185afac7da3a3d153f65d9a899d988c (diff)
downloadaur-cbcf28f1878370dbd2e4211597a8c734e0768654.tar.gz
[upd] Sync to sdl2 package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4127532d94ab..f1bd128432fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,30 @@
pkgbase = sdl2-hg
pkgdesc = A library for portable low-level access to video, audio and input (Version 2, development version)
- pkgver = 2.0.4.r3.d91a2c45825e
+ pkgver = 2.0.5.r423.2653833db94e
pkgrel = 1
url = http://www.libsdl.org
arch = i686
arch = x86_64
license = ZLIB
makedepends = mercurial
- makedepends = cmake
makedepends = alsa-lib
makedepends = mesa
makedepends = libpulse
makedepends = libxinerama
makedepends = libxkbcommon
makedepends = libxrandr
+ makedepends = wayland
+ makedepends = wayland-protocols
+ makedepends = ibus
+ makedepends = fcitx
+ makedepends = libxss
depends = sh
depends = libxext
depends = libxrender
depends = libx11
depends = libgl
depends = libxcursor
+ depends = libsamplerate
optdepends = alsa-lib: ALSA audio driver
optdepends = libpulse: PulseAudio audio driver
provides = sdl2
diff --git a/PKGBUILD b/PKGBUILD
index c93822002429..2823a8c6cad6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Axper Jan <483ken at gmail dot com>
pkgname=sdl2-hg
-pkgver=2.0.4.r3.d91a2c45825e
+pkgver=2.0.5.r423.2653833db94e
pkgrel=1
pkgdesc="A library for portable low-level access to video, audio and input (Version 2, development version)"
arch=('i686' 'x86_64')
@@ -13,8 +13,9 @@ url="http://www.libsdl.org"
license=('ZLIB')
provides=('sdl2')
conflicts=('sdl2')
-depends=('sh' 'libxext' 'libxrender' 'libx11' 'libgl' 'libxcursor')
-makedepends=('mercurial' 'cmake' 'alsa-lib' 'mesa' 'libpulse' 'libxinerama' 'libxkbcommon' 'libxrandr')
+depends=('sh' 'libxext' 'libxrender' 'libx11' 'libgl' 'libxcursor' 'libsamplerate')
+makedepends=('mercurial' 'alsa-lib' 'mesa' 'libpulse' 'libxinerama' 'libxkbcommon'
+ 'libxrandr' 'wayland' 'wayland-protocols' 'ibus' 'fcitx' 'libxss')
optdepends=('alsa-lib: ALSA audio driver'
'libpulse: PulseAudio audio driver')
source=(sdl2::"hg+http://hg.libsdl.org/SDL")
@@ -36,9 +37,13 @@ prepare() {
build() {
cd build
- cmake ../sdl2 -DCMAKE_INSTALL_PREFIX=/usr \
- -DARTS=OFF -DNAS=OFF -DESD=OFF -DRPATH=OFF -DVIDEO_WAYLAND=OFF \
- -DSDL_STATIC=OFF # -DSDL_DLOPEN=ON -DSDL_SHARED=ON
+ ../sdl2/configure --prefix=/usr \
+ --enable-sdl-dlopen \
+ --disable-arts --disable-esd --disable-nas \
+ --enable-alsa --enable-pulseaudio-shared \
+ --enable-video-wayland \
+ --enable-ibus --enable-fcitx \
+ --disable-rpath
make
}