summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Manenti2022-06-28 20:09:47 +0100
committerAndrea Manenti2022-06-28 20:09:47 +0100
commitd23e66673a5b06bc35a9eafb0fc0334cfdaa66f3 (patch)
treeab4c4c9efd47f56f55bd4ab0b8dd7dbf1f3c0cd0
parentf73adf697f57af2a32be65374923bd0bba68842c (diff)
downloadaur-d23e66673a5b06bc35a9eafb0fc0334cfdaa66f3.tar.gz
Removed patch since the fix has now been merged
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--string_file_deprecated.patch72
3 files changed, 4 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c56dd058a7f..f71e611c2dfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdpb-git
pkgdesc = Semidefinite program solver designed for the conformal bootstrap
- pkgver = 1515.ec2e4cb
+ pkgver = 1517.428b7ee
pkgrel = 1
url = https://arxiv.org/abs/1909.09745
arch = x86_64
@@ -15,8 +15,6 @@ pkgbase = sdpb-git
depends = elemental-gmp-git
optdepends = openmpi
source = git+https://github.com/davidsd/sdpb.git
- source = string_file_deprecated.patch
sha256sums = SKIP
- sha256sums = 9273625b2f3a0fbd4f8fa048defd77abd48f3f0c9d39aa9a3d92e88a7057fca0
pkgname = sdpb-git
diff --git a/PKGBUILD b/PKGBUILD
index 940050f0272e..38fd4da05151 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrea Manenti <andrea [dot] manenti [at] yahoo [dot] com>
pkgname=sdpb-git
-pkgver=1515.ec2e4cb
+pkgver=1517.428b7ee
pkgrel=1
pkgdesc="Semidefinite program solver designed for the conformal bootstrap"
arch=(x86_64)
@@ -10,10 +10,8 @@ url="https://arxiv.org/abs/1909.09745"
depends=('boost' 'libarchive' 'libxml2' 'mpfr' 'rapidjson' 'elemental-gmp-git')
optdepends=('openmpi')
makedepends=('git' 'python')
-source=('git+https://github.com/davidsd/sdpb.git'
- 'string_file_deprecated.patch')
-sha256sums=('SKIP'
- '9273625b2f3a0fbd4f8fa048defd77abd48f3f0c9d39aa9a3d92e88a7057fca0')
+source=('git+https://github.com/davidsd/sdpb.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir"/sdpb
@@ -22,7 +20,6 @@ pkgver() {
build () {
cd "$srcdir"/sdpb
- git apply "$srcdir"/string_file_deprecated.patch
python waf configure --prefix=/usr
python waf
diff --git a/string_file_deprecated.patch b/string_file_deprecated.patch
deleted file mode 100644
index 8d87922786d7..000000000000
--- a/string_file_deprecated.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-diff --git a/src/pvm2functions/write_functions.cxx b/src/pvm2functions/write_functions.cxx
-index 46da35b..f8b9c07 100644
---- a/src/pvm2functions/write_functions.cxx
-+++ b/src/pvm2functions/write_functions.cxx
-@@ -1,6 +1,7 @@
- #include "../Boost_Float.hxx"
- #include "../sdp_convert.hxx"
- #include "../sdp_convert/write_vector.hxx"
-+#include <boost/filesystem/string_file.hpp>
-
- void write_functions(
- const boost::filesystem::path &output_path,
-diff --git a/src/sdp_read.hxx b/src/sdp_read.hxx
-index eb191a5..b5d6625 100644
---- a/src/sdp_read.hxx
-+++ b/src/sdp_read.hxx
-@@ -2,6 +2,7 @@
-
- #include "sdp_read/read_input.hxx"
- #include "sdp_read/read_pvm_input.hxx"
-+#include <boost/filesystem/string_file.hpp>
-
- std::vector<boost::filesystem::path>
- read_file_list(const boost::filesystem::path &input_file);
-diff --git a/src/sdp_solve/SDP/SDP/read_blocks/read_blocks.cxx b/src/sdp_solve/SDP/SDP/read_blocks/read_blocks.cxx
-index 87afec1..204cd1b 100644
---- a/src/sdp_solve/SDP/SDP/read_blocks/read_blocks.cxx
-+++ b/src/sdp_solve/SDP/SDP/read_blocks/read_blocks.cxx
-@@ -3,6 +3,7 @@
- #include "../../../Archive_Reader.hxx"
-
- #include <algorithm>
-+#include <boost/filesystem/string_file.hpp>
-
- namespace
- {
-diff --git a/src/sdp_solve/SDP_Solver/load_checkpoint/load_text_checkpoint.cxx b/src/sdp_solve/SDP_Solver/load_checkpoint/load_text_checkpoint.cxx
-index 834eb59..51317e9 100644
---- a/src/sdp_solve/SDP_Solver/load_checkpoint/load_text_checkpoint.cxx
-+++ b/src/sdp_solve/SDP_Solver/load_checkpoint/load_text_checkpoint.cxx
-@@ -2,6 +2,7 @@
- #include "../../read_text_block.hxx"
-
- #include <boost/filesystem/fstream.hpp>
-+#include <boost/filesystem/string_file.hpp>
-
- bool load_text_checkpoint(const boost::filesystem::path &checkpoint_directory,
- const std::vector<size_t> &block_indices,
-diff --git a/src/sdp_solve/read_text_block.hxx b/src/sdp_solve/read_text_block.hxx
-index d06b725..42e4e35 100644
---- a/src/sdp_solve/read_text_block.hxx
-+++ b/src/sdp_solve/read_text_block.hxx
-@@ -3,6 +3,7 @@
- #include <El.hpp>
-
- #include <boost/filesystem.hpp>
-+#include <boost/filesystem/string_file.hpp>
-
- inline void
- set_element(El::DistMatrix<El::BigFloat> &block, const int64_t &row,
-diff --git a/src/spectrum/write_spectrum/write_file.cxx b/src/spectrum/write_spectrum/write_file.cxx
-index d4a749c..23dd11c 100644
---- a/src/spectrum/write_spectrum/write_file.cxx
-+++ b/src/spectrum/write_spectrum/write_file.cxx
-@@ -2,6 +2,7 @@
- #include "../../set_stream_precision.hxx"
-
- #include <boost/filesystem.hpp>
-+#include <boost/filesystem/string_file.hpp>
-
- void write_file(const boost::filesystem::path &output_path,
- const std::vector<Zeros> &zeros_blocks)