summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2017-07-12 12:15:23 +0000
committerBalló György2017-07-12 12:15:23 +0000
commitf1100a694a15a5418367a3fc2de4a293a1943f95 (patch)
tree883be46bf2b25ca5154d6fee09d7f82844c59509
downloadaur-seahorse-sharing.tar.gz
Add back seahorse-sharing package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7291eae26d2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = seahorse-sharing
+ pkgdesc = PGP public key sharing using DNS-SD and HKP
+ pkgver = 3.8.0
+ pkgrel = 1
+ url = https://git.gnome.org/browse/seahorse-sharing/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = libsm
+ depends = avahi
+ depends = gpgme
+ depends = gtk3
+ depends = libsoup
+ source = https://download.gnome.org/sources/seahorse-sharing/3.8/seahorse-sharing-3.8.0.tar.xz
+ sha256sums = e216e7d5709e688e142b4e96710759f5be54c39ac6c2d58f2eec330e4dfef92b
+
+pkgname = seahorse-sharing
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54c3a9aa00c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=seahorse-sharing
+pkgver=3.8.0
+pkgrel=1
+pkgdesc="PGP public key sharing using DNS-SD and HKP"
+arch=('i686' 'x86_64')
+url="https://git.gnome.org/browse/seahorse-sharing/"
+license=('GPL')
+depends=('avahi' 'gpgme' 'gtk3' 'libsoup')
+makedepends=('intltool' 'libsm')
+source=(https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
+sha256sums=('e216e7d5709e688e142b4e96710759f5be54c39ac6c2d58f2eec330e4dfef92b')
+
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i 's/accepted_versions="1.2 1.4 2.0"/accepted_versions="1.2 1.4 2.0 2.1"/' configure.ac
+ autoreconf -fi
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}