summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormdraw2017-07-11 17:09:46 +0200
committermdraw2017-07-11 17:09:46 +0200
commitdf77d7462a5c8449a00466ab8e6aa8e391a04714 (patch)
tree292303b05480065a4dfd59bb1e7a87fc7d20ee3a
downloadaur-seashells.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6278e27f98a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Jul 11 15:09:37 UTC 2017
+pkgbase = seashells
+ pkgdesc = Pipe output from CLI programs to seashells.io in real-time
+ pkgver = 0.1.2
+ pkgrel = 0
+ url = https://github.com/anishathalye/seashells
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ conflicts = seashells-git
+ source = https://github.com/anishathalye/seashells/archive/v0.1.2.tar.gz
+ sha256sums = bb6e659ae2e5da76786a185246116137bf6062865591b07fb842911070135ccf
+
+pkgname = seashells
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7aeabb970f89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: mdraw.gh@gmail.com
+
+pkgname=seashells
+pkgver=0.1.2
+pkgrel=0
+pkgdesc='Pipe output from CLI programs to seashells.io in real-time'
+url='https://github.com/anishathalye/seashells'
+license=('MIT')
+arch=('any')
+depends=('python')
+makedepends=('python-setuptools')
+conflicts=('seashells-git')
+source=("https://github.com/anishathalye/seashells/archive/v${pkgver}.tar.gz")
+sha256sums=('bb6e659ae2e5da76786a185246116137bf6062865591b07fb842911070135ccf')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+