summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-06-29 18:27:54 +0430
committerMohammadreza Abdollahzadeh2018-06-29 18:27:54 +0430
commit3f7a2d4fbada99173038271aa39aff11a736ae64 (patch)
treea5d9b66b457552a91f548738f14f55dc6a63a993
downloadaur-seiscomp3-git.tar.gz
initial import
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD55
-rw-r--r--seiscomp3.sh3
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af0fbfa89b2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Fri Jun 29 13:57:32 UTC 2018
+pkgbase = seiscomp3-git
+ pkgdesc = A seismological software for data acquisition, processing, distribution and interactive analysis.
+ pkgver = r1147.e32a75d5
+ pkgrel = 1
+ url = https://github.com/SeisComP3/seiscomp3
+ arch = x86_64
+ license = custom
+ makedepends = boost
+ makedepends = cmake
+ makedepends = git
+ makedepends = libmariadbclient
+ makedepends = postgresql-libs
+ makedepends = python2-sphinx
+ depends = boost-libs
+ depends = libxml2
+ depends = mariadb
+ depends = ncurses
+ depends = openssl
+ depends = python2
+ depends = python2-m2crypto
+ depends = qt4
+ optdepends = postgresql: for using PostgreSQL database
+ provides = seiscomp3
+ conflicts = seiscomp3
+ source = seiscomp3::git+https://github.com/SeisComP3/seiscomp3.git
+ source = seiscomp3.sh
+ sha256sums = SKIP
+ sha256sums = 06157296f7cbc1fda7c09254b91143fc0463fe238133ebbff6437165e3000761
+
+pkgname = seiscomp3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93648b305f38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=seiscomp3-git
+pkgver=r1147.e32a75d5
+pkgrel=1
+pkgdesc="A seismological software for data acquisition, processing, distribution and interactive analysis."
+arch=('x86_64')
+url="https://github.com/SeisComP3/seiscomp3"
+license=('custom')
+depends=('boost-libs' 'libxml2' 'mariadb' 'ncurses' 'openssl' 'python2' 'python2-m2crypto' 'qt4')
+makedepends=('boost' 'cmake' 'git' 'libmariadbclient' 'postgresql-libs' 'python2-sphinx')
+optdepends=('postgresql: for using PostgreSQL database')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+${url}.git"
+ "seiscomp3.sh")
+sha256sums=('SKIP'
+ '06157296f7cbc1fda7c09254b91143fc0463fe238133ebbff6437165e3000761')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ sed -i "s/python/python2/g" ./doc/CMakeLists.txt
+ sed -i "s/sphinx-build/sphinx-build2/g" ./doc/build-doc.py
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd "${pkgname%-git}/build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/opt/seiscomp3' \
+ -DCMAKE_CXX_FLAGS='-fPIC' \
+ -DCMAKE_SHARED_LINKER_FLAGS='-fPIC' \
+ -DCMAKE_EXE_LINKER_FLAGS='-fPIC -lpthread' \
+ -DPYTHON_EXECUTABLE='/usr/bin/python2' \
+ -DSC_DOC_GENERATE='ON'
+ make
+}
+
+package() {
+ cd "${pkgname%-git}/build"
+ make DESTDIR="${pkgdir}/" install
+ install -Dm644 "${srcdir}/seiscomp3.sh" "${pkgdir}/etc/profile.d/seiscomp3.sh"
+ install -Dm644 "${srcdir}/${pkgname%-git}/COPYING" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
+ find "${pkgdir}/opt/seiscomp3" -type f -exec sed -i "s/env python/env python2/g" '{}' \;
+}
+# vim:set ts=2 sw=2 et:
diff --git a/seiscomp3.sh b/seiscomp3.sh
new file mode 100644
index 000000000000..9bc0abd9e0f8
--- /dev/null
+++ b/seiscomp3.sh
@@ -0,0 +1,3 @@
+export PATH=${PATH}:/opt/seiscomp3/bin
+export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/opt/seiscomp3/lib
+export MANPATH=${MANPATH}:/opt/seiscomp3/share/man