summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2021-10-11 21:43:11 +0200
committerNicolas Iooss2021-10-12 23:01:05 +0200
commitad4ec2d62b918770e217b932d1238b73b5542935 (patch)
tree15a28dfb740473384f143b6b671e2ca4c4e8f7f2
parent0e9cbb87485e1964c1ddb4969d2c2dfececd8e27 (diff)
downloadaur-selinux-refpolicy-git.tar.gz
selinux-refpolicy-git: move configuration step into build()
https://wiki.archlinux.org/title/creating_packages describes that prepare() is used to prepare the source. Running actions similar to "./configure" (here it is "make conf") should happen in build().
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 3 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b412b871b2f4..f434a55656d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = selinux-refpolicy-git
pkgdesc = Modular SELinux reference policy including headers and docs
- pkgver = RELEASE_2_20210203.r23.g1167739da188
+ pkgver = RELEASE_2_20210908.r29.ge49243a08f4d
pkgrel = 1
url = https://github.com/SELinuxProject/refpolicy/wiki
install = selinux-refpolicy-git.install
@@ -18,4 +18,3 @@ pkgbase = selinux-refpolicy-git
sha256sums = a5faaa2a2c3f986770a9296882b1887c2bdd38b0a990a36f95fe22f22ffb5c13
pkgname = selinux-refpolicy-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6888cec07fb4..db12ca319f04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=selinux-refpolicy-git
_policyname=refpolicy-git
-pkgver=RELEASE_2_20210203.r23.g1167739da188
+pkgver=RELEASE_2_20210908.r29.ge49243a08f4d
pkgrel=1
pkgdesc="Modular SELinux reference policy including headers and docs"
arch=('any')
@@ -29,7 +29,7 @@ pkgver() {
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
+build() {
cd refpolicy
# Ensure the environment is clean
@@ -37,10 +37,7 @@ prepare() {
# Configure, overriding build.conf values with the ones given on the command line
make conf NAME="${_policyname}" DISTRO=arch SYSTEMD=y UBAC=n
-}
-build() {
- cd refpolicy
make NAME="${_policyname}" DISTRO=arch SYSTEMD=y UBAC=n
}