summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjadelord2016-01-02 22:00:08 +0100
committerjadelord2016-01-02 22:00:08 +0100
commit7d17986ca0dcbb31caa6d2cc2a1fdb9b794b0d74 (patch)
tree0d869bfb35a96f42eea0d8ebc58076076dfbebaa
parent70756daba0b28f2ff1fa5497e0354d55008654ea (diff)
downloadaur-7d17986ca0dcbb31caa6d2cc2a1fdb9b794b0d74.tar.gz
Properly added sources for diff archs.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68b23af852c7..776c6818f178 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
# Generated by mksrcinfo v8
-# Sat Jan 2 14:13:16 UTC 2016
+# Sat Jan 2 20:56:59 UTC 2016
pkgbase = sendanywhere
pkgdesc = Send Anywhere, a peer-to-peer file sharing service
pkgver = 1.12.18
- pkgrel = 0
+ pkgrel = 1
url = https://send-anywhere.com
install = sendanywhere.install
- arch = any
+ arch = i686
+ arch = x86_64
license = custom:sendanywhere_eula
makedepends = dpkg
provides = sendanywhere
- source = https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb
- sha256sums = ad0168f85fbc2f3051a630dbd1621d5c48b2f2d32cfd76c961da391b57a10122
+ source_i686 = https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_i386.deb
+ sha256sums_i686 = ffdac92b5cce6e48af1c6cde2d2917ac6432089e7c327ccb2be1f7800609a974
+ source_x86_64 = https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb
+ sha256sums_x86_64 = ad0168f85fbc2f3051a630dbd1621d5c48b2f2d32cfd76c961da391b57a10122
pkgname = sendanywhere
diff --git a/PKGBUILD b/PKGBUILD
index 6ed7f0d1b643..2d6f96483920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=sendanywhere
pkgver=1.12.18
-pkgrel=0
+pkgrel=1
pkgdesc="Send Anywhere, a peer-to-peer file sharing service"
-arch=('any')
+arch=('i686' 'x86_64')
url="https://send-anywhere.com"
license=('custom:sendanywhere_eula')
provides=('sendanywhere')
@@ -13,16 +13,13 @@ makedepends=('dpkg')
install=$pkgname.install
if [[ $CARCH = i686 ]];then
- _arch=i386
- sha256sums=('ffdac92b5cce6e48af1c6cde2d2917ac6432089e7c327ccb2be1f7800609a974')
+ sha256sums_i686=('ffdac92b5cce6e48af1c6cde2d2917ac6432089e7c327ccb2be1f7800609a974')
+ source_i686=("https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_i386.deb")
else
- _arch=amd64
- sha256sums=('ad0168f85fbc2f3051a630dbd1621d5c48b2f2d32cfd76c961da391b57a10122')
+ sha256sums_x86_64=('ad0168f85fbc2f3051a630dbd1621d5c48b2f2d32cfd76c961da391b57a10122')
+ source_x86_64=("https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb")
fi
-_filename="sendanywhere_latest_${_arch}.deb"
-source=("https://update.send-anywhere.com/linux_downloads/$_filename")
-
package() {
echo '==> Extracting with dpkg.'
dpkg -x "$srcdir/$_filename" "$pkgdir"