summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Fischer2018-03-21 11:56:39 +0100
committerAaron Fischer2018-03-21 11:56:39 +0100
commite7083c5441ae8a9886b0897138f06ca406324e32 (patch)
treef1d8b986d3d15604c176b3744927e88658e15829
parent031ca3f5dbe19e6c20027bf2c1414c68a6c2cf79 (diff)
downloadaur-e7083c5441ae8a9886b0897138f06ca406324e32.tar.gz
Rewrite the complete package and bump it up to the newest version
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD46
-rw-r--r--sendanywhere.install39
3 files changed, 21 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ad20d62b51a..ecc4f2ab0ca6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,15 @@
-# Generated by mksrcinfo v8
-# Sun Jun 25 12:03:14 UTC 2017
pkgbase = sendanywhere
- pkgdesc = Direct file sharing across all platforms/devices. Send Anywhere is a multi-platform file sharing service where users can directly share digital content in real time.
- pkgver = latest
+ pkgdesc = Send Anywhere is a multi-platform file sharing service where users can directly share digital content in real time.
+ pkgver = 8.2.13
pkgrel = 1
- url = https://www.send-anywhere.com
- install = sendanywhere.install
- arch = i686
+ url = http://send-anywhere.com
arch = x86_64
license = custom:sendanywhere_eula
- makedepends = chrpath
- makedepends = xdg-utils
- makedepends = desktop-file-utils
- depends = postgresql-libs
- depends = qt5-svg
depends = gtk3
- depends = libmariadbclient
- provides = sendanywhere
- source_i686 = https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_i386.deb
- md5sums_i686 = SKIP
- source_x86_64 = https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb
- md5sums_x86_64 = SKIP
+ options = !strip
+ options = !emptydirs
+ source = https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb
+ sha512sums = 294525a6440a8eb7a263993ee655a57b1f40c76c476e231ec1b974e8a3a85dfdc763555be368e200a21d065746f2e271855ee34a6107e308618b6cdd0d1a0532
pkgname = sendanywhere
diff --git a/PKGBUILD b/PKGBUILD
index aa7123b80b93..04ef08eb504b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,21 @@
-# Maintainer: Ashwin Vishnu <ashuwish+arch at gmail dot com>
+# Maintainer: Aaron Fischer <mail@aaron-fischer.net>
+# Contributor: Ashwin Vishnu <ashuwish+arch at gmail dot com>
pkgname=sendanywhere
-pkgver=latest
+pkgver=8.2.13
pkgrel=1
-pkgdesc="Direct file sharing across all platforms/devices. Send Anywhere is a multi-platform file sharing service where users can directly share digital content in real time."
-arch=('i686' 'x86_64')
-url="https://www.send-anywhere.com"
+pkgdesc="Send Anywhere is a multi-platform file sharing service where users can directly share digital content in real time."
+arch=('x86_64')
+url="http://send-anywhere.com"
license=('custom:sendanywhere_eula')
-provides=('sendanywhere')
-makedepends=('chrpath' 'xdg-utils' 'desktop-file-utils')
-install=$pkgname.install
-depends=('postgresql-libs' 'qt5-svg' 'gtk3' 'libmariadbclient')
-source_i686=("https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_i386.deb")
-source_x86_64=("https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb")
-md5sums_i686=('SKIP')
-md5sums_x86_64=('SKIP')
+options=('!strip' '!emptydirs')
+depends=('gtk3')
+source=('https://update.send-anywhere.com/linux_downloads/sendanywhere_latest_amd64.deb')
+sha512sums=('294525a6440a8eb7a263993ee655a57b1f40c76c476e231ec1b974e8a3a85dfdc763555be368e200a21d065746f2e271855ee34a6107e308618b6cdd0d1a0532')
-prepare() {
- bsdtar xJf data.tar.xz
- bsdtar xzf control.tar.gz
- echo '==> Checking integrity with MD5sums.'
- md5sum -c md5sums --strict --quiet
+package(){
+ tar xf data.tar.xz -C "$pkgdir"
- # Remove insecure RPATH
- chrpath --delete "opt/estmob/sendanywhere/sendanywhere"
-}
-
-pkgver() {
- awk -F": " '/Version/{print $2}' control
-}
-
-package() {
- mv usr opt $pkgdir
-
- echo '==> Copying license.'
- install -Dm644 "$pkgdir/usr/share/doc/sendanywhere/copyright" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- rm -r "$pkgdir/usr/share/doc"
+ install -Dm644 "$pkgdir/opt/SendAnywhere/LICENSE.electron.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.electron.txt"
+ install -Dm644 "$pkgdir/opt/SendAnywhere/LICENSES.chromium.html" "$pkgdir/usr/share/licenses/$pkgname/LICENSES.chromium.html"
}
diff --git a/sendanywhere.install b/sendanywhere.install
deleted file mode 100644
index 7c2613083c71..000000000000
--- a/sendanywhere.install
+++ /dev/null
@@ -1,39 +0,0 @@
-post_install()
-{
- echo '==> Installing icons.'
- for icon in "/opt/estmob/sendanywhere/sendanywhere_icon_"*.png; do
- size="${icon##*_}"
- size="${size%.png}"
-
- xdg-icon-resource install --size "$size" "$icon" "estmob-sendanywhere"
- done
-
- update-mime-database /usr/share/mime &> /dev/null 2> /dev/null
- update-desktop-database > /dev/null 2>&1
-}
-
-post_upgrade()
-{
- post_install
-}
-
-
-pre_remove()
-{
- echo '==> Uninstalling icons.'
- for icon in "/opt/estmob/sendanywhere/sendanywhere_icon_"*.png; do
- size="${icon##*_}"
- size="${size%.png}"
-
- xdg-icon-resource uninstall --size "$size" "$icon" "estmob-sendanywhere"
- done
-
- update-mime-database /usr/share/mime &> /dev/null
- update-desktop-database > /dev/null 2>&1
-}
-
-post_remove()
-{
- rm -rf "$HOME/.local/share/Estmob"
- rm -rf "$HOME/.config/autostart/sendanywhere.desktop"
-}