summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author46792016-04-11 11:28:46 +0800
committer46792016-04-11 11:28:46 +0800
commitedddfa4a4473aa8de19d9c4f8bd383fe0affae34 (patch)
tree3e80aa9b66dfe5eba7bc6caf60a11043fec696f1
downloadaur-servicectl.tar.gz
initial
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..522c44a7165e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Apr 11 03:27:59 UTC 2016
+pkgbase = servicectl
+ pkgdesc = Control daemons for systemd in chroot environment
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/smaknsk/servicectl
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL
+ depends = systemd
+ source = https://github.com/smaknsk/servicectl/archive/1.0.tar.gz
+ md5sums = 22230a7c9c599147b7feb4d5333b612d
+
+pkgname = servicectl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d51295d39abb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: 4679kun <4679kun@outlook.com>
+# Contributor: Alexander Sobolevkiy <smak.nsk@gmail.com>
+
+pkgname=servicectl
+pkgver=1.0
+pkgrel=1
+pkgdesc="Control daemons for systemd in chroot environment"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/smaknsk/servicectl"
+license=('GPL')
+depends=('systemd')
+source=("https://github.com/smaknsk/servicectl/archive/${pkgver}.tar.gz")
+md5sums=('22230a7c9c599147b7feb4d5333b612d')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+
+ mkdir -p "${pkgdir}/usr/lib/servicectl/enabled" || return 1
+ install -D -m 755 servicectl "${pkgdir}/usr/lib/servicectl/servicectl" || return 1
+ install -D -m 755 serviced "${pkgdir}/usr/lib/servicectl/serviced" || return 1
+ cp {README.md,README_ru.md} "${pkgdir}/usr/lib/servicectl/" || return 1
+
+ mkdir -p "${pkgdir}/usr/bin" || return 1
+ ln -s "/usr/lib/servicectl/servicectl" "${pkgdir}/usr/bin/servicectl" || return 1
+ ln -s "/usr/lib/servicectl/serviced" "${pkgdir}/usr/bin/serviced" || return 1
+}