summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2020-10-02 09:02:05 -0400
committerAndrew Sun2020-10-02 09:02:05 -0400
commit49d8b60f0d8185ca6b91d0664441090638b7a66c (patch)
tree653a5b74db21cebe9c1d29f4610ba14040f20394
parent4f8afe65aa4bc89b93ded1edd2a15bcca08108a1 (diff)
downloadaur-49d8b60f0d8185ca6b91d0664441090638b7a66c.tar.gz
1.3.9
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ead8bd2ce417..47178dc391e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = sfcgal
pkgdesc = Wrapper around the CGAL library that intents to implement 2D and 3D operations on OGC standards models
- pkgver = 1.3.8
+ pkgver = v1.3.9
pkgrel = 1
- url = https://oslandia.github.io/SFCGAL/index.html
+ url = https://gitlab.com/Oslandia/SFCGAL
arch = i686
arch = x86_64
license = GPL2
+ makedepends = git
makedepends = cmake
depends = cgal>=4.1
depends = boost
@@ -13,8 +14,8 @@ pkgbase = sfcgal
depends = mpfr
depends = openscenegraph
provides = sfcgal
- source = sfcgal-1.3.8.tar.gz::https://github.com/Oslandia/SFCGAL/archive/v1.3.8.tar.gz
- sha256sums = 5154bfc67a5e99d95cb653d70d2b9d9293d3deb3c8f18b938a33d68fec488a6d
+ source = git+https://gitlab.com/Oslandia/SFCGAL#commit=823db7a318b8841f8296e80036ef993ddf19ebf5
+ sha256sums = SKIP
pkgname = sfcgal
diff --git a/PKGBUILD b/PKGBUILD
index eaa9c1736751..ec07e5240d71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,26 @@
# Contributor: Hannes Graeuler < hgraeule [at] uos [dot] de >
pkgname=sfcgal
-pkgver=1.3.8
+pkgver=v1.3.9
pkgrel=1
pkgdesc="Wrapper around the CGAL library that intents to implement 2D and 3D operations on OGC standards models"
arch=('i686' 'x86_64')
-url="https://oslandia.github.io/SFCGAL/index.html"
+url="https://gitlab.com/Oslandia/SFCGAL"
license=('GPL2')
provides=('sfcgal')
depends=('cgal>=4.1' 'boost' 'gmp' 'mpfr' 'openscenegraph')
-makedepends=('cmake')
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/Oslandia/SFCGAL/archive/v${pkgver}.tar.gz")
-sha256sums=('5154bfc67a5e99d95cb653d70d2b9d9293d3deb3c8f18b938a33d68fec488a6d')
+makedepends=('git' 'cmake')
+_commit=823db7a318b8841f8296e80036ef993ddf19ebf5 # tags/1.3.9^0
+source=("git+${url}#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/SFCGAL"
+ git describe --tags | sed 's/-/+/g'
+}
build() {
- cd ${srcdir}/SFCGAL-${pkgver}
+ cd "${srcdir}/SFCGAL"
mkdir -p build && cd build
cmake -Wno-dev \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -28,7 +34,7 @@ build() {
}
package() {
- cd ${srcdir}/SFCGAL-${pkgver}/build
+ cd ${srcdir}/SFCGAL/build
make DESTDIR=${pkgdir} install
# Remove conflict with cgal package
rm -rf ${pkgdir}/usr/include/CGAL