summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannes Gräuler2015-07-05 12:58:09 +0200
committerHannes Gräuler2015-07-05 12:58:09 +0200
commit5d45936acce2ba4c8feb6e2f1c9bd147983d0e2c (patch)
tree8e01b4d63f683dcd9f7cfa620046d5fd47fc218c
downloadaur-5d45936acce2ba4c8feb6e2f1c9bd147983d0e2c.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4de6ce493095
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sfcgal
+ pkgdesc = Wrapper around the CGAL library that intents to implement 2D and 3D operations on OGC standards models
+ pkgver = 1.0.5
+ pkgrel = 2
+ url = http://oslandia.github.io/SFCGAL/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = cgal>=4.1
+ depends = boost
+ depends = gmp
+ depends = mpfr
+ depends = openscenegraph
+ source = https://github.com/Oslandia/SFCGAL/archive/v1.0.5.tar.gz
+ sha1sums = 816de09566d37b1dd5c6813be56c2c02a9765244
+
+pkgname = sfcgal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eef070aed4ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Hannes Graeuler < hgraeule [at] uos [dot] de >
+pkgname=sfcgal
+pkgver=1.0.5
+pkgrel=2
+pkgdesc="Wrapper around the CGAL library that intents to implement 2D and 3D operations on OGC standards models"
+arch=(i686 x86_64)
+url="http://oslandia.github.io/SFCGAL/index.html"
+license=('GPL')
+groups=
+provides=
+depends=('cgal>=4.1' 'boost' 'gmp' 'mpfr' 'openscenegraph')
+makedepends=('cmake')
+source=("https://github.com/Oslandia/SFCGAL/archive/v$pkgver.tar.gz")
+sha1sums=('816de09566d37b1dd5c6813be56c2c02a9765244')
+
+build() {
+ cd $srcdir/SFCGAL-$pkgver
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DSFCGAL_BUILD_VIEWER=1 \
+ -DSFCGAL_BUILD_EXAMPLES=1 \
+ -DSFCGAL_BUILD_TEST=1 .
+ make
+}
+package() {
+ cd $srcdir/SFCGAL-$pkgver
+ make DESTDIR=$pkgdir install
+ rm -rf $pkgdir/usr/include/CGAL
+}