summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorperqin2019-03-24 18:48:15 +0800
committerperqin2019-03-24 18:48:15 +0800
commitda220c00e279e1bd52a9cd7fef0a4d290c870b1d (patch)
tree68306c5c914c4d6ef366835d2e2900b6d7c20ed3
parentc641bd1c8d4d69b69cec8d36398323a12225c729 (diff)
downloadaur-shadowsocksrr-libev-git.tar.gz
Build over branch Akkariiin/develop
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
-rw-r--r--shadowsocksrr-libev.install3
-rw-r--r--shadowsocksrr-libev.sh1
4 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0530795d4be0..2ab2bfd54b45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = shadowsocksrr-libev-git
pkgdesc = A ShadowsocksR fork
- pkgver = 2.5.3.r0.gd63ff86
- pkgrel = 3
+ pkgver = 2.5.3.r1584.ed6c9eb
+ pkgrel = 1
url = https://github.com/shadowsocksrr/shadowsocksr-libev
- arch = i686
arch = x86_64
license = GPL3
makedepends = git
@@ -18,7 +17,7 @@ pkgbase = shadowsocksrr-libev-git
optdepends = mbedtls: another choice of SSL/TLS library
options = docs
options = !strip
- source = shadowsocksrr-libev-git::git+https://github.com/shadowsocksrr/shadowsocksr-libev.git#tag=2.5.3
+ source = shadowsocksrr-libev-git::git+https://github.com/shadowsocksrr/shadowsocksr-libev.git#branch=Akkariiin/develop
source = shadowsocksrr-libev-redir@.service
source = shadowsocksrr-libev-server@.service
source = shadowsocksrr-libev-tunnel@.service
diff --git a/PKGBUILD b/PKGBUILD
index 491daa91dc4d..0cf4eb1c0cf9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: perqin <perqinxie at gmail dot com>
pkgname=shadowsocksrr-libev-git
-pkgver=2.5.3.r0.gd63ff86
-pkgrel=3
+pkgver=2.5.3.r1584.ed6c9eb
+pkgrel=1
pkgdesc='A ShadowsocksR fork'
-arch=('i686' 'x86_64')
+# Removed i386 because the maintainer hasn't tested this package over it
+arch=('x86_64')
url='https://github.com/shadowsocksrr/shadowsocksr-libev'
license=('GPL3')
depends=('openssl' 'libev' 'libsodium' 'udns' 'pcre')
@@ -12,7 +13,7 @@ makedepends=('git' 'zlib' 'asciidoc' 'xmlto')
optdepends=('mbedtls: another choice of SSL/TLS library') # choose this or openssl as you wish
options=('docs' '!strip')
source=(
- 'shadowsocksrr-libev-git::git+https://github.com/shadowsocksrr/shadowsocksr-libev.git#tag=2.5.3'
+ 'shadowsocksrr-libev-git::git+https://github.com/shadowsocksrr/shadowsocksr-libev.git#branch=Akkariiin/develop'
shadowsocksrr-libev-redir@.service
shadowsocksrr-libev-server@.service
shadowsocksrr-libev-tunnel@.service
@@ -28,7 +29,7 @@ pkgver() {
cd "$pkgname"
( set -o pipefail
git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "2.5.3.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
diff --git a/shadowsocksrr-libev.install b/shadowsocksrr-libev.install
deleted file mode 100644
index a1859b01ed03..000000000000
--- a/shadowsocksrr-libev.install
+++ /dev/null
@@ -1,3 +0,0 @@
-post_install() {
- echo "You need to relogin in order for the SSRR binaries to appear in your PATH"
-}
diff --git a/shadowsocksrr-libev.sh b/shadowsocksrr-libev.sh
deleted file mode 100644
index ec0baaa74f2d..000000000000
--- a/shadowsocksrr-libev.sh
+++ /dev/null
@@ -1 +0,0 @@
-export PATH=${PATH}:/opt/shadowsocksrr-libev/bin