summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjimmytheneutrino2018-04-30 16:01:02 +0200
committerjimmytheneutrino2018-04-30 16:01:02 +0200
commitbeaae594a8e438089567439efeb19199f0b02cd2 (patch)
treefa792d2d4d00430e438e462a5a97042b916b558c
downloadaur-sharelatex-git-integration-unofficial-git.tar.gz
first
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..356aadec7cbb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sharelatex-git-integration-unofficial-git
+ pkgdesc = Easily track your ShareLaTeX changes using git. One simple command to rule them all!
+ pkgver = 36
+ pkgrel = 1
+ url = https://github.com/Jorl17/sharelatex-git-integration-unofficial
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-distribute
+ depends = python-requests
+ depends = python-beautifulsoup4
+ source = git+https://github.com/Jorl17/sharelatex-git-integration-unofficial.git
+ md5sums = SKIP
+
+pkgname = sharelatex-git-integration-unofficial-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..576d9dc7d6df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Aleksei Lissitsin <aleksei.lissitsin 'at' gmail 'dot' com>
+
+_pkgname=sharelatex-git-integration-unofficial
+pkgname=${_pkgname}-git
+pkgver=36
+pkgrel=1
+pkgdesc="Easily track your ShareLaTeX changes using git. One simple command to rule them all!"
+arch=('any')
+url="https://github.com/Jorl17/sharelatex-git-integration-unofficial"
+license=('GPL')
+depends=('python-requests' 'python-beautifulsoup4')
+makedepends=('git' 'python-distribute')
+source=("git+https://github.com/Jorl17/sharelatex-git-integration-unofficial.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git rev-list --count HEAD
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root=${pkgdir}
+} \ No newline at end of file