summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-11-08 19:07:14 -0500
committerfrealgagu2018-11-08 19:07:14 -0500
commit4564d303a3803ffb19690511ed00d50af5c0bead (patch)
treeba1198ac656ea9e8d6828aa54834472ebf3c85c6
parent624d73a1d8a1686fc074e217ef2df9f19239b85a (diff)
downloadaur-shashlik-bin.tar.gz
Fixing pkgver sed range. Compiling in chroot.
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD19
3 files changed, 8 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a91eb4e9aaa..a141f03c18fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,8 +6,8 @@ pkgbase = shashlik-bin
arch = x86_64
license = GPL
depends = lib32-libgl
+ depends = python
optdepends = kdialog
- optdepends = python
provides = shashlik
conflicts = shashlik
source = shashlik-bin-0.9.3.deb::http://static.davidedmundson.co.uk/shashlik/shashlik_0.9.3.deb
diff --git a/.gitignore b/.gitignore
index 24b48cdaa635..61f3e259e6ba 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
shashlik-bin-*.pkg.tar.xz
shashlik-bin-*.deb
+shashlik-bin-*.log
+PKGBUILD-namcap.log
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 86c436aeafb5..7aa8d1eccfde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,34 +7,25 @@ pkgver=0.9.3
pkgrel=4
pkgdesc="A way to run Android applications on a standard Linux desktop as easily and simply as possible"
arch=("x86_64")
-url="http://www.shashlik.io"
+url="http://www.${pkgname%-bin}.io"
license=("GPL")
-depends=("lib32-libgl")
-optdepends=("kdialog" "python")
+depends=("lib32-libgl" "python")
+optdepends=("kdialog")
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
-source=("${pkgname}-${pkgver}.deb::http://static.davidedmundson.co.uk/shashlik/${pkgname%-bin}_${pkgver}.deb")
+source=("${pkgname}-${pkgver}.deb::http://static.davidedmundson.co.uk/${pkgname%-bin}/${pkgname%-bin}_${pkgver}.deb")
sha256sums=("a0a9daaeea0436ec8bd90b97112694974f7cf121d5a54083244488ff2d86dbaa")
build() {
cd "${srcdir}"
-
- msg2 "Extracting data from debian package"
bsdtar -xf data.tar.xz -C .
-
- msg2 "Adding write permissions to folder /opt/shashlik/android/system"
- chmod u+w "${srcdir}/opt/shashlik/android/system"
+ chmod u+w "${srcdir}/opt/${pkgname%-bin}/android/system"
}
package() {
cd "${srcdir}"
-
install -dm755 "${pkgdir}/usr/bin"
-
- msg2 "Installing application into /opt/${pkgname}"
cp -r "${srcdir}/opt" "${pkgdir}/"
-
- msg2 "Creating links into /usr/bin"
ln -s /opt/${pkgname%-bin}/bin/${pkgname%-bin}-run "${pkgdir}/usr/bin/"
ln -s /opt/${pkgname%-bin}/bin/${pkgname%-bin}-install "${pkgdir}/usr/bin/"
}