summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-04-01 13:13:40 -0400
committeréclairevoyant2023-04-01 13:13:40 -0400
commit6255bb1d7a4373102fcef2dfccb4988fbaaf74e7 (patch)
tree83247f854480e6c57f834db806af1e8b0fcb456e
parent29f2e99b0265d5dfefc362bdb4383f9e28805f8d (diff)
downloadaur-shc-git.tar.gz
shc-git: add deps; fix pkgver, license
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
2 files changed, 33 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f7130fef07c..244647b6e3bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = shc-git
- pkgdesc = A generic shell script compiler.
- pkgver = 4.0.3
+ pkgdesc = Generic shell script compiler
+ pkgver = 4.0.3.r10.6495e11e
pkgrel = 1
url = https://github.com/neurobin/shc
- arch = any
- license = GPLv3
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = glibc
provides = shc
conflicts = shc
- source = shc::git+https://github.com/neurobin/shc.git
- md5sums = SKIP
+ source = git+https://github.com/neurobin/shc.git
+ b2sums = SKIP
pkgname = shc-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 492b99055eb4..6b18cf2d98a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,37 @@
-# Maintainer: wangjiezhe <wangjiezhe AT yandex DOT com>
+# Maintainer: éclairevoyant
-pkgname=shc-git
_pkgname=shc
-pkgver=4.0.3
+pkgname=shc-git
+pkgver=4.0.3.r10.6495e11e
pkgrel=1
-pkgdesc="A generic shell script compiler."
-arch=('any')
-url="https://github.com/neurobin/shc"
-license=('GPLv3')
-provides=("shc")
-conflicts=("shc")
-source=("$_pkgname::git+${url}.git")
-md5sums=('SKIP')
+pkgdesc="Generic shell script compiler"
+arch=(x86_64)
+url="https://github.com/neurobin/$_pkgname"
+license=(GPL3)
+depends=(glibc)
+makedepends=(git)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+b2sums=('SKIP')
pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/^v//;s/-/./g'
+ cd $_pkgname
+ git blame -s -L"/^PACKAGE_VERSION=/,+1" configure | awk '{
+ ver = gensub(/[^0-9.]/, "", "g", $3);
+ "git rev-list --count "$1"..HEAD" | getline commit_count;
+ print ver".r"commit_count"."$1
+ }'
}
build() {
- cd $_pkgname
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ cd $_pkgname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
}
package() {
- cd $_pkgname
- make DESTDIR="$pkgdir/" install
+ cd $_pkgname
+ make DESTDIR="$pkgdir/" install
}