summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Gómez2021-04-05 20:52:35 -0500
committerAndrea Gómez2021-04-05 20:52:35 -0500
commit53f5ad9e73ace1fdb1bd09088d6d2a731637f70b (patch)
tree199704cac2c2f5c11f2d8478ad7da48f07c1a167
parent917e27db7d3789fc457b2d7c2aef1a97274bf6d2 (diff)
downloadaur-shhgit.tar.gz
Updated according to Go package guidelines
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD39
2 files changed, 30 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02147de125af..19cfc5fa5abb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = shhgit
- pkgdesc = Find GitHub secrets in real time.
+ pkgdesc = Secrets detection for your GitHub, GitLab and Bitbucket repositories
pkgver = 0.2
pkgrel = 1
url = https://github.com/eth0izzle/shhgit
arch = x86_64
arch = i686
- arch = arm
- arch = armv6h
arch = armv7h
- arch = aarch64
license = MIT
- makedepends = go-pie
+ makedepends = go
provides = shhgit
conflicts = shhgit
source = shhgit-0.2.tar.gz::https://github.com/eth0izzle/shhgit/archive/v0.2.tar.gz
sha256sums = 0cce46f6474f1885b3bce057b8370017248cf3d7a4e16ddb91a6d2c626163680
+ sha512sums = eb28f297e40c0dd437cad561bc3f877d9e9a7261553394c8b649ec2aa009574a2ec66d5ccefd82dfd461f92aec75324a723f6de332c9d23cb785d3cc0d959320
+ b2sums = 79ee37cea7ec7c5eb45847548135bf51e9c956803a03d5ee37af1c501aed88e55d1a0822d464b1a6f20040c113127ab01c909bdcafef205226fd0a87d12868aa
pkgname = shhgit
diff --git a/PKGBUILD b/PKGBUILD
index 30a7b2d7eb0b..8476aa80fa87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,44 @@
-# Maintainer: Andrea 'alephZer0' Gómez <crypto.andrea at protonmail dot ch> -> https://github.com/da-edra
+# Maintainer: Andrea Denisse Gómez-Martínez <aur at denisse dot dev>
pkgname=shhgit
+pkgdesc='Secrets detection for your GitHub, GitLab and Bitbucket repositories'
+arch=(x86_64 i686 armv7h)
+url='https://github.com/eth0izzle/shhgit'
+_branch='master'
pkgver=0.2
pkgrel=1
-pkgdesc="Find GitHub secrets in real time."
-arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/eth0izzle/shhgit"
license=('MIT')
-depends=()
-makedepends=('go-pie')
-provides=("shhgit")
-conflicts=("shhgit")
+makedepends=(go)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha256sums=('0cce46f6474f1885b3bce057b8370017248cf3d7a4e16ddb91a6d2c626163680')
+sha512sums=('eb28f297e40c0dd437cad561bc3f877d9e9a7261553394c8b649ec2aa009574a2ec66d5ccefd82dfd461f92aec75324a723f6de332c9d23cb785d3cc0d959320')
+b2sums=('79ee37cea7ec7c5eb45847548135bf51e9c956803a03d5ee37af1c501aed88e55d1a0822d464b1a6f20040c113127ab01c909bdcafef205226fd0a87d12868aa')
+provides=($pkgname)
+conflicts=($pkgname)
prepare() {
- export GO111MODULE=on
+ mkdir -p "${pkgname}-${pkgver}/build"
}
build() {
cd "${pkgname}-${pkgver}"
- go build
+
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ go build -o build/ .
}
-package() {
+check() {
cd "${pkgname}-${pkgver}"
+ go test ./...
+}
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dsm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}