summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-09-06 18:50:02 +0000
committerDaniel Bermond2019-09-06 18:50:02 +0000
commite50b068be5bcc4b9300a92c9e9b714fca14944e4 (patch)
tree6fc422d188a4ac5d3af657377433a1c999cbd3e4
parentf1e06aa2a4f34f3168fe319e9c194ea900c7d632 (diff)
downloadaur-shim-efi.tar.gz
Fix build with gcc9
References ---------- https://github.com/rhboot/shim/pull/183
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f93e283e6dd4..9f02c9dd0da7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = shim-efi
pkgdesc = Bootloader for UEFI Secure Boot
pkgver = 15
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/rhboot/shim/
arch = any
license = BSD
makedepends = gnu-efi-libs
makedepends = pesign
source = shim-efi-15.tar.bz2::https://github.com/rhboot/shim/releases/download/15/shim-15.tar.bz2
+ source = shim-efi-gcc9-fix.patch::https://patch-diff.githubusercontent.com/raw/rhboot/shim/pull/183.patch
sha256sums = 473720200e6dae7cfd3ce7fb27c66367a8d6b08233fe63f01aa1d6b3888deeb6
+ sha256sums = b2d2db78a77a4257a95acab9bcb1f1243e230a714748538c915c3173b41e0657
pkgname = shim-efi
diff --git a/PKGBUILD b/PKGBUILD
index 99b281cdf5ca..9efc160a4327 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,28 @@
# Contributor: Keshav Amburay <the.ridikulus.rat@gmail.com>
pkgname=shim-efi
-_srcname=shim
pkgver=15
-pkgrel=2
+pkgrel=3
pkgdesc='Bootloader for UEFI Secure Boot'
url='https://github.com/rhboot/shim/'
arch=('any')
license=('BSD')
makedepends=('gnu-efi-libs' 'pesign')
-source=("${pkgname}-${pkgver}.tar.bz2"::"https://github.com/rhboot/shim/releases/download/${pkgver}/shim-${pkgver}.tar.bz2")
-sha256sums=('473720200e6dae7cfd3ce7fb27c66367a8d6b08233fe63f01aa1d6b3888deeb6')
+source=("${pkgname}-${pkgver}.tar.bz2"::"https://github.com/rhboot/shim/releases/download/${pkgver}/shim-${pkgver}.tar.bz2"
+ "${pkgname}-gcc9-fix.patch"::'https://patch-diff.githubusercontent.com/raw/rhboot/shim/pull/183.patch')
+sha256sums=('473720200e6dae7cfd3ce7fb27c66367a8d6b08233fe63f01aa1d6b3888deeb6'
+ 'b2d2db78a77a4257a95acab9bcb1f1243e230a714748538c915c3173b41e0657')
+
+prepare() {
+ cd "shim-${pkgver}"
+
+ # gcc9 fix
+ # https://github.com/rhboot/shim/pull/183
+ patch -Np1 -i "${srcdir}/${pkgname}-gcc9-fix.patch"
+}
build() {
- cd "${_srcname}-${pkgver}"
+ cd "shim-${pkgver}"
export EFI_PATH='/usr/lib'
export ENABLE_HTTPBOOT='1'
@@ -26,7 +35,7 @@ build() {
}
package() {
- cd "${_srcname}-${pkgver}"
+ cd "shim-${pkgver}"
make DESTDIR="$pkgdir" install-as-data