summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetar Petrov2018-03-04 20:20:39 +0100
committerPetar Petrov2018-03-04 20:22:31 +0100
commitcfec9e06a879c39d19795da7c8e46aacdfd9c6e0 (patch)
tree7a8c38c11da33fe302246feefd7090e8edfea473
downloadaur-shut-up-bird.tar.gz
Initial commit -> version 1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
-rw-r--r--shut-up-bird.install9
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b80e6abf616
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = shut-up-bird
+ pkgdesc = Create an ePub e-book from your Twitter posts or likes and then (optionally) delete them from your timeline.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/petarov/shut-up-bird
+ install = shut-up-bird.install
+ arch = any
+ license = MIT
+ depends = python
+ source = https://github.com/petarov/shut-up-bird/archive/1.0.tar.gz
+ sha1sums = 1677c6dba6cc6187ac0b27cabd4e53f617708985
+
+pkgname = shut-up-bird
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1da90b096808
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Petar Petrov <petar.petrov.georgiev at gmail d0t com>
+pkgname=shut-up-bird
+pkgver=1.0
+pkgrel=1
+pkgdesc="Create an ePub e-book from your Twitter posts or likes and then (optionally) delete them from your timeline."
+arch=('any')
+url="https://github.com/petarov/shut-up-bird"
+license=('MIT')
+groups=()
+depends=('python')
+makedepends=('python-pip')
+checkdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=shut-up-bird.install
+source=(https://github.com/petarov/shut-up-bird/archive/$pkgver.tar.gz)
+sha1sums=('1677c6dba6cc6187ac0b27cabd4e53f617708985')
+
+runname='ead'
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -Dm755 ${pkgname}.py ${pkgdir}/usr/bin/${pkgname}.py
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/shut-up-bird.install b/shut-up-bird.install
new file mode 100644
index 000000000000..d061d2229dd9
--- /dev/null
+++ b/shut-up-bird.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo
+ echo Disclaimer
+ echo ---------------------
+ echo Please note that shut-up-bird is a hobby project. I SHALL NOT be held liable in case you lose any data by using this tool!
+ echo ----------------------
+ echo
+}
+