summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2018-08-05 11:10:23 +0200
committerAlbert Graef2018-08-05 11:10:23 +0200
commit94e3a1e9d3e99772d8c02596430c0d9f821d6912 (patch)
treea049257f5870ede8c030fcc128c98effde800b88
downloadaur-shuttlepro-git.tar.gz
Initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33d91961f4c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Aug 5 09:09:44 UTC 2018
+pkgbase = shuttlepro-git
+ pkgdesc = a user program for interpreting input from a Contour Design Shuttle device (git version)
+ pkgver = 0.1.r0.ga77ed7a
+ pkgrel = 1
+ url = https://github.com/agraef/ShuttlePRO
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = libxtst
+ depends = jack
+ provides = shuttlepro
+ conflicts = shuttlepro
+ source = shuttlepro-git::git+https://github.com/agraef/ShuttlePRO.git
+ md5sums = SKIP
+
+pkgname = shuttlepro-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90f56228a2b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: aggraef@gmail.com
+pkgname=shuttlepro-git
+pkgver=0.1.r0.ga77ed7a
+pkgrel=1
+pkgdesc="a user program for interpreting input from a Contour Design Shuttle device (git version)"
+arch=('x86_64' 'i686')
+# This is my own updated version with many enhancements, forked from
+# https://github.com/nanosyzygy/ShuttlePRO.
+url="https://github.com/agraef/ShuttlePRO"
+license=('GPL')
+depends=('libxtst' 'jack')
+provides=('shuttlepro')
+conflicts=('shuttlepro')
+source=("$pkgname::git+https://github.com/agraef/ShuttlePRO.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make install prefix=/usr DESTDIR="$pkgdir"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -m644 README.md LICENSE "$pkgdir/usr/share/doc/$pkgname"
+}