summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122020-09-01 13:38:26 +0200
committerwillemw122020-09-01 13:38:26 +0200
commit53a3149f4258175539f3335ce5253f9fc699e39e (patch)
tree793b7137d2642d5e9992429b6c02d3c16d7944d1
parent7cbb7b11914b9c28cfdc2767f2a221c8c9a1642e (diff)
downloadaur-53a3149f4258175539f3335ce5253f9fc699e39e.tar.gz
Migrate to Python 3 (develop branch)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
-rw-r--r--sickchill.service4
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10d8553fd911..3c67ce1a3348 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
pkgbase = sickchill-git
pkgdesc = Automatic video library manager for TV shows
- pkgver = 2020.01.17.1.r0.g760c6ca2a
+ pkgver = 2020.07.09.1.r266.g319d20e55
pkgrel = 1
url = https://github.com/SickChill/SickChill
install = sickchill-git.install
arch = any
license = GPL3
makedepends = git
+ makedepends = python-pygithub
depends = nodejs
- depends = python2
+ depends = python
optdepends = unrar: for RAR archives
provides = sickchill
conflicts = sickchill
options = !strip
- source = sickchill-git::git+https://github.com/SickChill/SickChill.git
+ source = sickchill-git::git+https://github.com/SickChill/SickChill.git#branch=develop
source = sickchill.service
source = sickchill.sysusers
source = sickchill.tmpfile
md5sums = SKIP
- md5sums = 5f5c96bdeb4eb5665af2bcebf0ceca53
+ md5sums = fe1030d29e883682a9c3117867edd9d8
md5sums = 97fb191af2e326d5aba2cf58270b4feb
md5sums = 515f13e391105a716ef6763ba8533fc7
diff --git a/PKGBUILD b/PKGBUILD
index 33f4a79976c3..d68a267a85b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=sickchill-git
-pkgver=2020.07.18.1.r0.gc67114a85
+pkgver=2020.07.09.1.r266.g319d20e55
pkgrel=1
pkgdesc="Automatic video library manager for TV shows"
arch=('any')
url="https://github.com/SickChill/SickChill"
license=('GPL3')
-depends=('nodejs' 'python2')
-makedepends=('git')
+depends=('nodejs' 'python')
+makedepends=('git' 'python-pygithub')
# 'deluge: supported torrent client'
# 'qbittorrent: supported torrent client'
# 'rtorrent: supported torrent client'
@@ -19,12 +19,13 @@ provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
options=('!strip')
install=$pkgname.install
-source=("$pkgname::git+$url.git"
+#source=("$pkgname::git+$url.git"
+source=("$pkgname::git+$url.git#branch=develop"
'sickchill.service'
'sickchill.sysusers'
'sickchill.tmpfile')
md5sums=('SKIP'
- '5f5c96bdeb4eb5665af2bcebf0ceca53'
+ 'fe1030d29e883682a9c3117867edd9d8'
'97fb191af2e326d5aba2cf58270b4feb'
'515f13e391105a716ef6763ba8533fc7')
@@ -35,12 +36,12 @@ pkgver() {
#build() {
# cd $pkgname
-# python2 setup.py --quiet build
+# python setup.py --quiet build
#}
#check() {
# cd $pkgname
-# python2 setup.py test
+# python setup.py test
#}
package() {
@@ -52,7 +53,7 @@ package() {
# The install type is "source": .git folder is not included
#cd $pkgname
- #python2 setup.py install --prefix=/opt/sickchill/app --install-lib=/opt/sickchill/app --root="$pkgdir" --optimize=1
+ #python setup.py install --prefix=/opt/sickchill/app --install-lib=/opt/sickchill/app --root="$pkgdir" --optimize=1
cp -a $pkgname/* "$pkgdir/opt/sickchill/app/"
warning "If the upgrade fails with \"error: failed to commit transaction (conflicting files)\", then uninstall first"
diff --git a/sickchill.service b/sickchill.service
index 7f3cb032ea85..4c9bbe4f76b0 100644
--- a/sickchill.service
+++ b/sickchill.service
@@ -8,8 +8,8 @@ User=sickchill
Group=sickchill
Type=simple
-#ExecStart=/usr/bin/env python2 ...
-ExecStart=/usr/bin/python2 /opt/sickchill/app/SickBeard.py --quiet --nolaunch --datadir=/opt/sickchill/data
+Environment=PYTHONPATH=/opt/sickchill/app/lib3
+ExecStart=/opt/sickchill/app/SickChill.py --quiet --nolaunch --datadir=/opt/sickchill/data
[Install]
WantedBy=multi-user.target