summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122017-01-17 10:36:39 +0100
committerwillemw122017-01-17 10:36:39 +0100
commit5ed87c374d2fc6382911e3d8610a253ee2b3fd0b (patch)
tree8bed013edd18c533854e0f5185571fd20f6ca95a
parentc4dfce72636b0ad1db78b321ef0753b04a57328a (diff)
downloadaur-5ed87c374d2fc6382911e3d8610a253ee2b3fd0b.tar.gz
Retrieve version number from pip
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae0c275d201b..4c042b2b8d59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = sickrage-pip
pkgdesc = A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage, torrents and anime support.
- pkgver = 8.6.1.r2.ge5f0fae
+ pkgver = 8.9.2.r0
pkgrel = 1
url = https://github.com/SiCKRAGETV/SickRage
install = sickrage-pip.install
arch = any
license = GPL3
- makedepends = git
depends = python2-virtualenv
optdepends = unrar: RAR archives
provides = sickrage
conflicts = sickrage
options = !strip
- source = sickrage-pip::git://github.com/SiCKRAGETV/SickRage.git
source = sickrage.service
source = sickrage.sysusers
source = sickrage.tmpfile
- md5sums = SKIP
md5sums = 3d67651fa77e6f2a0c37a995ad20bc2f
md5sums = 6a7db7e14e74072d29e482b06b41dfa7
md5sums = f7a12df978d649da4e77d88e03f50252
diff --git a/PKGBUILD b/PKGBUILD
index f4b5abbe4317..671028d89353 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: willemw <willemw12@gmail.com>
# Contibutor: Justin Dray <justin@dray.be>
+# Contibutor: B4SH-B00STER
_pkgname=sickrage
pkgname=$_pkgname-pip
-pkgver=8.6.1.r2.ge5f0fae
+pkgver=8.9.2.r0
pkgrel=1
pkgdesc="A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage, torrents and anime support."
arch=('any')
url="https://github.com/SiCKRAGETV/SickRage"
license=('GPL3')
-makedepends=('git')
depends=('python2-virtualenv')
# 'deluge: supported torrent client'
# 'qbittorrent: supported torrent client'
@@ -21,16 +21,17 @@ provides=($_pkgname)
conflicts=($_pkgname)
options=('!strip')
install=$pkgname.install
-source=("$pkgname::git://github.com/SiCKRAGETV/SickRage.git"
- 'sickrage.service' 'sickrage.sysusers' 'sickrage.tmpfile')
-md5sums=('SKIP'
- '3d67651fa77e6f2a0c37a995ad20bc2f'
+source=('sickrage.service'
+ 'sickrage.sysusers'
+ 'sickrage.tmpfile')
+md5sums=('3d67651fa77e6f2a0c37a995ad20bc2f'
'6a7db7e14e74072d29e482b06b41dfa7'
'f7a12df978d649da4e77d88e03f50252')
pkgver() {
- cd $pkgname
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ #pip2 search $_pkgname | awk '$1 == "sickrage" { gsub("[()]", ""); print $2 ".r0" }'
+ #curl -s https://pypi.python.org/pypi/$_pkgname/json | grep version | head -1 | awk -F: '{ print $2 }' | awk -F'"' '$0=$2 ".r0"'
+ curl -s https://pypi.python.org/pypi/$_pkgname/json | awk -F'"' '$2 == "version" { print $4 ".r0" }'
}
package() {