summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordhead6662015-07-07 18:37:12 +0300
committerdhead6662015-07-07 18:37:12 +0300
commit150dbcfb02b96c3fef1f105efc8c0af0c144454f (patch)
treed239ab1ad7bedaa749fed9eafdb6c3f2d856fdd4
downloadaur-sidplay-libs.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
-rw-r--r--sidplay-libs-01-m4-tests.patch26
-rw-r--r--sidplay-libs-02-inherited.patch26
-rw-r--r--sidplay-libs-03-operator.patch11
-rw-r--r--sidplay-libs-04-includes.patch30
6 files changed, 161 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ef52a80ca92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = sidplay-libs
+ pkgdesc = The new generation of SID emulation
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = http://sidplay2.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ source = http://mirrors.xbmc.org/build-deps/sources/sidplay-libs-2.1.1.tar.gz
+ source = sidplay-libs-01-m4-tests.patch
+ source = sidplay-libs-02-inherited.patch
+ source = sidplay-libs-03-operator.patch
+ source = sidplay-libs-04-includes.patch
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = sidplay-libs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2dbf26082246
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: dhead666 <myfoolishgames@gmail.com>
+# https://github.com/dhead666/archlinux-pkgbuilds
+#
+
+pkgname=sidplay-libs
+pkgver=2.1.1
+pkgrel=1
+pkgdesc='The new generation of SID emulation'
+arch=('i686' 'x86_64')
+url="http://sidplay2.sourceforge.net"
+license=('GPL')
+makedepends=('cmake')
+source=(
+ "http://mirrors.xbmc.org/build-deps/sources/$pkgname-$pkgver.tar.gz"
+ 'sidplay-libs-01-m4-tests.patch'
+ 'sidplay-libs-02-inherited.patch'
+ 'sidplay-libs-03-operator.patch'
+ 'sidplay-libs-04-includes.patch')
+md5sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+_prefix='/usr'
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -p1 -i "$srcdir/sidplay-libs-01-m4-tests.patch"
+ patch -p1 -i "$srcdir/sidplay-libs-02-inherited.patch"
+ patch -p1 -i "$srcdir/sidplay-libs-03-operator.patch"
+ patch -p1 -i "$srcdir/sidplay-libs-04-includes.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=$_prefix --enable-shared --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/sidplay-libs-01-m4-tests.patch b/sidplay-libs-01-m4-tests.patch
new file mode 100644
index 000000000000..88592b0b7cd8
--- /dev/null
+++ b/sidplay-libs-01-m4-tests.patch
@@ -0,0 +1,26 @@
+--- sidplay-libs-2.1.1/libsidplay/unix/my_macros.m4.orig 2004-06-14 22:08:04.000000000 +0200
++++ sidplay-libs-2.1.1/libsidplay/unix/my_macros.m4 2013-11-18 01:23:32.195297135 +0100
+@@ -80,8 +80,8 @@
+ AC_CACHE_VAL(test_cv_have_ios_binary,
+ [
+ AC_TRY_COMPILE(
+- [#include <fstream.h>],
+- [ifstream myTest(ios::in|ios::binary);],
++ [#include <fstream>],
++ [std::ifstream myTest(std::ios::in|std::ios::binary);],
+ [test_cv_have_ios_binary=yes],
+ [test_cv_have_ios_binary=no]
+ )
+@@ -105,9 +105,9 @@
+ AC_CACHE_VAL(test_cv_have_ios_openmode,
+ [
+ AC_TRY_COMPILE(
+- [#include <fstream.h>
+- #include <iomanip.h>],
+- [ios::openmode myTest = ios::in;],
++ [#include <fstream>
++ #include <iomanip>],
++ [std::ios_base::openmode myTest = std::ios::in;],
+ [test_cv_have_ios_openmode=yes],
+ [test_cv_have_ios_openmode=no]
+ )
diff --git a/sidplay-libs-02-inherited.patch b/sidplay-libs-02-inherited.patch
new file mode 100644
index 000000000000..0e86eedf8024
--- /dev/null
+++ b/sidplay-libs-02-inherited.patch
@@ -0,0 +1,26 @@
+--- sidplay-libs-2.1.1/libsidplay/include/sidplay/SmartPtr.h.old 2013-11-18 00:40:16.679173012 +0100
++++ sidplay-libs-2.1.1/libsidplay/include/sidplay/SmartPtr.h 2013-11-18 00:41:22.451176157 +0100
+@@ -211,16 +211,16 @@
+ {
+ if ( bufferLen >= 1 )
+ {
+- pBufCurrent = ( bufBegin = buffer );
+- bufEnd = bufBegin + bufferLen;
+- bufLen = bufferLen;
+- status = true;
++ this->pBufCurrent = ( this->bufBegin = buffer );
++ this->bufEnd = this->bufBegin + bufferLen;
++ this->bufLen = bufferLen;
++ this->status = true;
+ }
+ else
+ {
+- pBufCurrent = bufBegin = bufEnd = 0;
+- bufLen = 0;
+- status = false;
++ this->pBufCurrent = this->bufBegin = this->bufEnd = 0;
++ this->bufLen = 0;
++ this->status = false;
+ }
+ }
+ };
diff --git a/sidplay-libs-03-operator.patch b/sidplay-libs-03-operator.patch
new file mode 100644
index 000000000000..88af8ccd34b5
--- /dev/null
+++ b/sidplay-libs-03-operator.patch
@@ -0,0 +1,11 @@
+--- sidplay-libs-2.1.1/libsidutils/include/sidplay/utils/SidUsage.h.orig 2013-11-18 00:58:06.111224154 +0100
++++ sidplay-libs-2.1.1/libsidutils/include/sidplay/utils/SidUsage.h 2013-11-18 00:58:28.219225212 +0100
+@@ -33,7 +33,7 @@
+ uint_least16_t length; // usage scan length
+
+ // Copy common parts of basic usage to extended usage.
+- sid2_usage_t &sid2_usage_t::operator= (const sid_usage_t &usage)
++ sid2_usage_t &operator= (const sid_usage_t &usage)
+ {
+ *((sid_usage_t *) this) = usage;
+ return *this;
diff --git a/sidplay-libs-04-includes.patch b/sidplay-libs-04-includes.patch
new file mode 100644
index 000000000000..ef9cf06017d6
--- /dev/null
+++ b/sidplay-libs-04-includes.patch
@@ -0,0 +1,30 @@
+--- sidplay-libs-2.1.1/builders/hardsid-builder/src/hardsid-builder.cpp.orig 2004-06-14 22:07:57.000000000 +0200
++++ sidplay-libs-2.1.1/builders/hardsid-builder/src/hardsid-builder.cpp 2013-11-18 01:01:50.399234880 +0100
+@@ -55,6 +55,7 @@
+
+ #include "hardsid.h"
+ #include "hardsid-emu.h"
++#include <string.h>
+
+
+ #ifdef HAVE_MSWINDOWS
+--- sidplay-libs-2.1.1/builders/resid-builder/src/resid.cpp.orig 2013-11-18 01:00:07.827229975 +0100
++++ sidplay-libs-2.1.1/builders/resid-builder/src/resid.cpp 2013-11-18 01:00:21.563230632 +0100
+@@ -24,6 +24,7 @@
+
+ #include "resid.h"
+ #include "resid-emu.h"
++#include <string.h>
+
+
+ char ReSID::m_credit[];
+--- sidplay-libs-2.1.1/builders/resid-builder/src/resid-builder.cpp.orig 2013-11-18 01:00:39.727231501 +0100
++++ sidplay-libs-2.1.1/builders/resid-builder/src/resid-builder.cpp 2013-11-18 01:00:57.415232346 +0100
+@@ -45,6 +45,7 @@
+
+ #include "resid.h"
+ #include "resid-emu.h"
++#include <string.h>
+
+ // Error String(s)
+ const char *ReSIDBuilder::ERR_FILTER_DEFINITION = "RESID ERROR: Filter definition is not valid (see docs).";