summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJanek Thomaschewski2018-05-02 04:22:38 +0200
committerJanek Thomaschewski2018-05-02 04:22:38 +0200
commite14c3145e0e774e2448105c24c63e89f2fbec317 (patch)
tree865c37f9c85b826eb92b1a915bb86a85438c0d21
parentc36a35ddfb4204dc1e46ecd8663ea95cf08ff2c3 (diff)
downloadaur-e14c3145e0e774e2448105c24c63e89f2fbec317.tar.gz
Fix permission issues
Some folders have now 775 in the upstream package of 1.9.0. They used to be 755 which causes issues when upgrading the package. This commit changes all 775 directory permissions to 755 to fix this issue.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19d9dab0af69..de2815e4a6af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = signal-desktop-bin
pkgdesc = Private messaging from your desktop
pkgver = 1.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/signalapp/Signal-Desktop
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 14f2c94904e2..62512458aba6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=signal-desktop-bin
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc='Private messaging from your desktop'
arch=('x86_64')
url='https://github.com/signalapp/Signal-Desktop'
@@ -21,6 +21,9 @@ package() {
# extract package data
tar xf data.tar.xz -C "${pkgdir}"
+ # fix permissions in 1.9.0 (Some directories have now 775; changing them back to 755)
+ find "${pkgdir}" -type d -not -perm 755 -exec chmod 755 {} \;
+
# install alias in /usr/bin
mkdir "${pkgdir}/usr/bin"
install -D -m755 signal-desktop "${pkgdir}/usr/bin/signal-desktop"