summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2023-10-21 23:23:33 +0300
committerAnton Kudelin2023-10-21 23:23:33 +0300
commit68e6cc6b7e9bad019415af59e77a9e2852dd8218 (patch)
tree777494430ae4432c1c0bc6fac9d412ffe2721798
parente0f6ac8a6e37a431401c0043ffc3f15dc1512542 (diff)
downloadaur-silo.tar.gz
updpkg: 4.11.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--hdf5-1.13.patch37
-rw-r--r--hdf5.patch44
4 files changed, 11 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e90c5031aa48..fcac6ea6bf6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = silo
pkgdesc = A Mesh and Field I/O Library and Scientific Database
- pkgver = 4.11
- pkgrel = 2
- url = https://llnl.github.io/Silo
+ pkgver = 4.11.1
+ pkgrel = 1
+ url = http://software.llnl.gov/Silo
arch = x86_64
license = BSD
makedepends = gcc-fortran
depends = qt5-base
depends = hdf5-openmpi
- source = https://github.com/LLNL/Silo/releases/download/v4.11/silo-4.11-bsd.tar.gz
- source = hdf5.patch
- source = hdf5-1.13.patch
- sha256sums = 6d0a85a079d48fcdcc0084ecb5fc4cfdcc64852edee780c60cb244d16f4bc4ec
- sha256sums = 8acf1a54c3ba21699a9f1cd67aabc806643630e80795bcf9524f7eb874116bb5
- sha256sums = fc94f615155dcb8e27c73c1f19392415081d25082fd11a7666df1886556ce368
+ source = https://github.com/LLNL/Silo/releases/download/4.11.1/silo-4.11.1-bsd.tar.xz
+ sha256sums = 51ccfdf3c09dfc98c7858a0a6f08cc3b2a07ee3c4142ee6482ba7b24e314c2aa
pkgname = silo
diff --git a/PKGBUILD b/PKGBUILD
index 238b450062fc..b2ec4bcce840 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,17 @@
# Contributor: Brenden Mervin <bmervin@utk.edu>
pkgname=silo
-pkgver=4.11
-pkgrel=2
+_PkgName=Silo
+pkgver=4.11.1
+pkgrel=1
pkgdesc="A Mesh and Field I/O Library and Scientific Database"
-url="https://llnl.github.io/Silo"
+url="http://software.llnl.gov/Silo"
arch=(x86_64)
depends=(qt5-base hdf5-openmpi)
makedepends=(gcc-fortran)
license=(BSD)
-source=(https://github.com/LLNL/Silo/releases/download/v$pkgver/$pkgname-$pkgver-bsd.tar.gz
- hdf5.patch
- hdf5-1.13.patch)
-sha256sums=('6d0a85a079d48fcdcc0084ecb5fc4cfdcc64852edee780c60cb244d16f4bc4ec'
- '8acf1a54c3ba21699a9f1cd67aabc806643630e80795bcf9524f7eb874116bb5'
- 'fc94f615155dcb8e27c73c1f19392415081d25082fd11a7666df1886556ce368')
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver-bsd"
- patch -p0 < ../hdf5.patch
- patch -p1 < ../hdf5-1.13.patch
- sed -i 's@rocket_silo.lo@rocket_silo.lo ../src/libsiloh5.la@' \
- tests/Makefile.in
-}
+source=(https://github.com/LLNL/$_PkgName/releases/download/$pkgver/$pkgname-$pkgver-bsd.tar.xz)
+sha256sums=('51ccfdf3c09dfc98c7858a0a6f08cc3b2a07ee3c4142ee6482ba7b24e314c2aa')
build() {
cd "$srcdir/$pkgname-$pkgver-bsd"
diff --git a/hdf5-1.13.patch b/hdf5-1.13.patch
deleted file mode 100644
index 161bc769f646..000000000000
--- a/hdf5-1.13.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 5dc160c7ae489b8181874dccf7ce3b8089c128f5 Mon Sep 17 00:00:00 2001
-From: Chuck Atkins <chuck.atkins@kitware.com>
-Date: Tue, 24 May 2022 10:57:29 -0400
-Subject: [PATCH] hdf5: Support the API changes in >= 1.13
-
----
- src/hdf5_drv/H5FDsilo.c | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
-diff --git a/src/hdf5_drv/H5FDsilo.c b/src/hdf5_drv/H5FDsilo.c
-index f4540456..74594c1b 100644
---- a/src/hdf5_drv/H5FDsilo.c
-+++ b/src/hdf5_drv/H5FDsilo.c
-@@ -550,6 +550,12 @@ typedef struct H5FD_class_t {
- #endif
-
- static const H5FD_class_t H5FD_silo_g = {
-+#if HDF5_VERSION_GE(1,13,2) && defined(H5FD_CLASS_VERSION)
-+ H5FD_CLASS_VERSION, /*version */
-+#endif
-+#if HDF5_VERSION_GE(1,13,0)
-+ 512, /*value */
-+#endif
- "silo", /*name */
- MAXADDR, /*maxaddr */
- H5F_CLOSE_WEAK, /* fc_degree */
-@@ -583,6 +589,10 @@ static const H5FD_class_t H5FD_silo_g = {
- H5FD_silo_truncate, /*truncate */
- NULL, /*lock */
- NULL, /*unlock */
-+#if HDF5_VERSION_GE(1,13,0)
-+ NULL, /*del */
-+ NULL, /*ctl */
-+#endif
- H5FD_FLMAP_SINGLE /*fl_map */
- };
-
diff --git a/hdf5.patch b/hdf5.patch
deleted file mode 100644
index 3a518475021e..000000000000
--- a/hdf5.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- src/hdf5_drv/H5FDsilo.c 2021-09-11 01:22:52.000000000 +0300
-+++ src/hdf5_drv/H5FDsilo.c 2021-11-25 00:37:06.685422949 +0200
-@@ -252,13 +252,13 @@
- snprintf(msg, sizeof(msg), Msg "(errno=%d, \"%s\")", \
- Errno, strerror(Errno)); \
- ret_value = Ret; \
-- H5Epush_ret(Func, Cls, Maj, Min, msg, Ret) \
-+ H5Epush_ret(Func, Cls, Maj, Min, msg, Ret); \
- }
- #else
- #define H5E_PUSH_HELPER(Func,Cls,Maj,Min,Msg,Ret,Errno) \
- { \
- ret_value = Ret; \
-- H5Epush_ret(Func, Cls, Maj, Min, Msg, Ret) \
-+ H5Epush_ret(Func, Cls, Maj, Min, Msg, Ret); \
- }
- #endif
-
-@@ -1355,7 +1355,7 @@
- assert(sizeof(hsize_t)<=8);
- memcpy(p, &file->block_size, sizeof(hsize_t));
- if (H5Tconvert(H5T_NATIVE_HSIZE, H5T_STD_U64LE, 1, buf+8, NULL, H5P_DEFAULT)<0)
-- H5Epush_ret(func, H5E_ERR_CLS, H5E_DATATYPE, H5E_CANTCONVERT, "can't convert superblock info", -1)
-+ H5Epush_ret(func, H5E_ERR_CLS, H5E_DATATYPE, H5E_CANTCONVERT, "can't convert superblock info", -1);
-
- return 0;
- }
-@@ -1383,14 +1383,14 @@
-
- /* Make sure the name/version number is correct */
- if (strcmp(name, "LLNLsilo"))
-- H5Epush_ret(func, H5E_ERR_CLS, H5E_FILE, H5E_BADVALUE, "invalid silo superblock", -1)
-+ H5Epush_ret(func, H5E_ERR_CLS, H5E_FILE, H5E_BADVALUE, "invalid silo superblock", -1);
-
- buf += 8;
- /* Decode block size */
- assert(sizeof(hsize_t)<=8);
- memcpy(x, buf, 8);
- if (H5Tconvert(H5T_STD_U64LE, H5T_NATIVE_HSIZE, 1, x, NULL, H5P_DEFAULT)<0)
-- H5Epush_ret(func, H5E_ERR_CLS, H5E_DATATYPE, H5E_CANTCONVERT, "can't convert superblock info", -1)
-+ H5Epush_ret(func, H5E_ERR_CLS, H5E_DATATYPE, H5E_CANTCONVERT, "can't convert superblock info", -1);
- ap = (hsize_t*)x;
- /*file->block_size = *ap; ignore stored value for now */
-