summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mugnai2022-08-20 18:16:58 +0200
committerMichael Mugnai2022-08-20 18:16:58 +0200
commite43399e62b242781f043c9a1da1e1cf288237744 (patch)
tree6725695c8f25caf23fa105650c4f62bcf5575d74
parent20b31ee71623e16320c333c1225327cb298f505f (diff)
downloadaur-simavr.tar.gz
patch some install commands
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--make_fix.patch17
3 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64b17211e0a2..88300b732ccc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = simavr
pkgdesc = A lean, mean and hackable AVR simulator
pkgver = 1.7
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/buserror-uk/simavr
arch = x86_64
license = GPL3
@@ -12,6 +12,8 @@ pkgbase = simavr
depends = glu
options = !strip
source = simavr::git+https://github.com/buserror-uk/simavr.git#commit=1d227277b3d0039f9faef9ea62880ca3051b14f8
+ source = local://make_fix.patch
md5sums = SKIP
+ md5sums = 885fa2f78b7f59ad8058115562c32441
pkgname = simavr
diff --git a/PKGBUILD b/PKGBUILD
index caf39fee2a74..f802d8ba42a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: schuay <jakob.gruber@gmail.com>
+# Contributor: Maik93 <michael.mugnai@gmail.com>
pkgname=simavr
pkgver=1.7
-pkgrel=2
+pkgrel=3
pkgdesc='A lean, mean and hackable AVR simulator'
arch=('x86_64')
url="https://github.com/buserror-uk/simavr"
@@ -10,9 +11,11 @@ license=('GPL3')
depends=('elfutils' 'glu')
makedepends=('avr-libc' 'git' 'freeglut')
_pkghash=1d227277b3d0039f9faef9ea62880ca3051b14f8
-source=("${pkgname}::git+https://github.com/buserror-uk/simavr.git#commit=${_pkghash}")
+source=("${pkgname}::git+https://github.com/buserror-uk/simavr.git#commit=${_pkghash}"
+ "local://make_fix.patch")
options=(!strip)
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '885fa2f78b7f59ad8058115562c32441')
build() {
cd "$srcdir/$pkgname"
@@ -20,6 +23,9 @@ build() {
make AVR_ROOT=/usr/avr RELEASE=1 \
CFLAGS="-Wall -Wextra -fPIC -O2 -std=gnu99 -Wno-sign-compare -Wno-unused-parameter" \
build-simavr
+
+ # fix some install commands
+ git apply "$srcdir/make_fix.patch"
}
package() {
diff --git a/make_fix.patch b/make_fix.patch
new file mode 100644
index 000000000000..7a937e40b5c0
--- /dev/null
+++ b/make_fix.patch
@@ -0,0 +1,17 @@
+diff --git a/examples/parts/Makefile b/examples/parts/Makefile
+index ba8bac6..0ae95cc 100644
+--- a/examples/parts/Makefile
++++ b/examples/parts/Makefile
+@@ -51,9 +51,9 @@ endif
+ install: obj ${target}
+ $(MKDIR) $(DESTDIR)/include/simavr/parts
+ $(INSTALL) -m644 *.h $(DESTDIR)/include/simavr/parts/
+- $(INSTALL) ${OBJ}/libsimavrparts.a $(DESTDIR)/lib/
+- sed -e "s|PREFIX|${PREFIX}|g" -e "s|VERSION|${SIMAVR_VERSION}|g" \
+- simavrparts.pc >$(DESTDIR)/lib/pkgconfig/simavrparts.pc
++ $(INSTALL) -Dm644 ${OBJ}/libsimavrparts.a $(DESTDIR)/lib/libsimavrparts.a
++ sed -i -e "s|PREFIX|${PREFIX}|g" -e "s|VERSION|${SIMAVR_VERSION}|g" simavrparts.pc
++ $(INSTALL) -Dm644 simavrparts.pc $(DESTDIR)/lib/pkgconfig/simavrparts.pc
+ ifeq (${shell uname}, Linux)
+ $(INSTALL) ${OBJ}/libsimavrparts.so.1 $(DESTDIR)/lib/
+ ln -sf libsimavrparts.so.1 $(DESTDIR)/lib/libsimavrparts.so