summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume BOEHM2023-12-30 14:17:30 +0100
committerGuillaume BOEHM2023-12-30 14:17:30 +0100
commit4205dbc6803e773e7ff5eae39604fbef30a4b239 (patch)
tree7854dda8677d88d3dc3fc07e3824178268863781
parent84be86cbf143f4925724d226c1193088020c88c7 (diff)
downloadaur-4205dbc6803e773e7ff5eae39604fbef30a4b239.tar.gz
fix: use pkgver in pkgname to avoid check fails
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c43c50cb752..9d84fce370a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = simplex-desktop-appimage
pkgdesc = The latest release of Simplex Desktop, the first messaging platform operating without user identifiers of any kind - 100% private by design!
pkgver = 5.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://simplex.chat/
arch = x86_64
license = AGPLv3
options = !strip
- source = https://github.com/simplex-chat/simplex-chat/releases/download/v5.4.2/simplex-desktop-x86_64.AppImage
+ source = simplex-desktop-x86_64-5.4.2-2.AppImage::https://github.com/simplex-chat/simplex-chat/releases/download/v5.4.2/simplex-desktop-x86_64.AppImage
sha512sums = 2a92627cefc63a4b04b9ca0e794b5f9fa56d69c492a0995bd39ff786885c09847bf20fb1384f03aaa12686c058a94f091237b2fb093345cea32866aa43b4086f
pkgname = simplex-desktop-appimage
diff --git a/PKGBUILD b/PKGBUILD
index 1ca56e541423..5f10d7c1a5c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=simplex-desktop-appimage
pkgver=5.4.2
-pkgrel=1
+pkgrel=2
pkgdesc="The latest release of Simplex Desktop, the first messaging platform operating without user identifiers of any kind - 100% private by design!"
arch=('x86_64')
url="https://simplex.chat/"
@@ -10,11 +10,11 @@ url="https://simplex.chat/"
license=('AGPLv3')
depends=()
options=(!strip) # necessary otherwise the AppImage file in the package is truncated
+_filename="simplex-desktop-${arch}-${pkgver}-${pkgrel}.AppImage"
source=(
- https://github.com/simplex-chat/simplex-chat/releases/download/v${pkgver}/simplex-desktop-${arch}.AppImage
+ "${_filename}::https://github.com/simplex-chat/simplex-chat/releases/download/v${pkgver}/simplex-desktop-${arch}.AppImage"
)
sha512sums=('2a92627cefc63a4b04b9ca0e794b5f9fa56d69c492a0995bd39ff786885c09847bf20fb1384f03aaa12686c058a94f091237b2fb093345cea32866aa43b4086f')
-_filename="simplex-desktop-${arch}.AppImage"
_squashfs_desktop_file="chat.simplex.app.desktop"
_desktop_file="/usr/share/applications/simplex-desktop.desktop"
_appimage_name=$(echo "${_filename}"|sed -E 's/-[0-9]*.[0-9]*.[0-9]*//')