summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume BOEHM2023-09-23 00:24:32 +0200
committerGuillaume BOEHM2023-09-23 00:24:32 +0200
commit81a6b6e192f3e0daf493aab55f9c7746a20c6310 (patch)
tree0abe866899ea2812da0522597930720916da8abd
downloadaur-81a6b6e192f3e0daf493aab55f9c7746a20c6310.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD51
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02b200a04689
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = simplex-desktop-appimage
+ pkgdesc = The latest release of Simplex Desktop, the first messaging platform operating without user identifiers of any kind - 100% private by design!
+ pkgver = 5.3.0
+ pkgrel = 1
+ url = https://simplex.chat/
+ arch = x86_64
+ license = AGPLv3
+ depends = zlib
+ depends = sdl2
+ depends = openal
+ depends = fuse2
+ options = !strip
+ source = https://github.com/simplex-chat/simplex-chat/releases/download/v5.3.0/simplex-desktop-x86_64.AppImage
+ sha512sums = fc3cbb3e972d15bf18908b47279a873639cbee99e4674db2269794cc104ab396616b8408bcde85d6696689ca32aa91a3d2688a15672b3cdaadd260aa7fc2e576
+
+pkgname = simplex-desktop-appimage
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb9c5fc90933
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+*/*
+**/*
+
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a72d6c52541
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: BOEHM Guillaume <aur@sl.gboehm.com>
+
+pkgname=simplex-desktop-appimage
+pkgver=5.3.0
+pkgrel=1
+pkgdesc="The latest release of Simplex Desktop, the first messaging platform operating without user identifiers of any kind - 100% private by design!"
+arch=('x86_64')
+url="https://simplex.chat/"
+
+license=('AGPLv3')
+depends=('zlib' 'sdl2' 'openal' 'fuse2')
+options=(!strip) # necessary otherwise the AppImage file in the package is truncated
+source=(
+ https://github.com/simplex-chat/simplex-chat/releases/download/v${pkgver}/simplex-desktop-${arch}.AppImage
+)
+sha512sums=(
+ fc3cbb3e972d15bf18908b47279a873639cbee99e4674db2269794cc104ab396616b8408bcde85d6696689ca32aa91a3d2688a15672b3cdaadd260aa7fc2e576
+)
+_filename="simplex-desktop-${arch}.AppImage"
+_squashfs_desktop_file="chat.simplex.app.desktop"
+_desktop_file="/usr/share/applications/simplex-desktop.desktop"
+_appimage_name=$(echo "${_filename}"|sed -E 's/-[0-9]*.[0-9]*.[0-9]*//')
+_install_path="/opt/appimages/${_appimage_name}"
+
+package() {
+
+ chmod +x "${_filename}"
+ # mkdir -p squashfs-root/usr/share/icons/hicolor/256x256/apps
+ ./${_filename} --appimage-extract "usr/share/icons/simplex.png" > /dev/null 2>&1
+ ./${_filename} --appimage-extract ${_squashfs_desktop_file} > /dev/null 2>&1
+
+ # install icons
+ install -dm755 "${pkgdir}/usr/share/icons/"
+ cp -dpr --no-preserve=ownership "squashfs-root/usr/share/icons/simplex.png" "${pkgdir}/usr/share/icons/"
+ chmod -R 755 "${pkgdir}/usr/share/icons"
+ find "${pkgdir}/usr/share/icons" -type f -name "simplex.png" -exec chmod 644 {} \;
+
+ # install .desktop file and image file
+ # disable appimage desktop integration: https://github.com/AppImage/AppImageSpec/blob/master/draft.md#desktop-integration
+ # disable AppimageLauncher integration prompt
+ # https://github.com/TheAssassin/AppImageLauncher/issues/78#issuecomment-466390939
+ sed -i -E "s|Exec=AppRun --no-sandbox %U|Exec=env DESKTOPINTEGRATION=0 APPIMAGELAUNCHER_DISABLE=1 /usr/bin/simplex --no-sandbox|" "squashfs-root/${_squashfs_desktop_file}"
+ install -Dm644 "squashfs-root/${_squashfs_desktop_file}" "${pkgdir}/${_desktop_file}"
+ install -Dm755 "${_filename}" "${pkgdir}/${_install_path}"
+ mkdir "${pkgdir}/usr/bin/" && chmod 755 "${pkgdir}/usr/bin/"
+ ln -s "${_install_path}" "${pkgdir}/usr/bin/simplex"
+
+ # disable AppImage integration prompt
+ # https://github.com/electron-userland/electron-builder/issues/1962
+ install -dm755 "${pkgdir}/usr/share/appimagekit"
+}