summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryantene2017-04-03 02:45:55 +0900
committeryantene2017-04-03 02:45:55 +0900
commit7893b82db43d61b0b6504372e8242d02782d96f6 (patch)
tree1ddd5153dbf3b633b8351b139f07650148d5cb8d
downloadaur-simstring-git.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5092d712345
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Apr 2 17:34:53 UTC 2017
+pkgbase = simstring-git
+ pkgdesc = A simple and efficient algorithm for approximate string matching
+ pkgver = 6209ea8
+ pkgrel = 1
+ url = http://www.chokkan.org/software/simstring/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = gcc-libs-multilib
+ provides = simstring
+ source = git+https://github.com/chokkan/simstring.git
+ md5sums = SKIP
+
+pkgname = simstring-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e74217e7954
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: yantene <contact@yantene.net>
+
+pkgname=simstring-git
+_gitname=simstring
+pkgver=6209ea8
+pkgrel=1
+pkgdesc="A simple and efficient algorithm for approximate string matching"
+url="http://www.chokkan.org/software/simstring/"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('gcc-libs-multilib')
+makedepends=('git')
+optdepends=()
+#depends+=()
+provides=('simstring')
+conflicts=()
+source=('git+https://github.com/chokkan/simstring.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ git describe --tags --always | sed -e 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $_gitname
+ ./autogen.sh
+}
+
+build() {
+ cd $_gitname
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_gitname
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/simstring-git/COPYING"
+}