summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2021-08-23 19:22:22 +0300
committerAnton Kudelin2021-08-23 19:22:22 +0300
commitfb9e4a262ca1236e4f678a879e3ced6f68a52637 (patch)
treea861fa56e9ca83f2dc6e98945e640adfb7241a73
parent3411dfdfb21592dc6b879c333573258f882de22d (diff)
downloadaur-fb9e4a262ca1236e4f678a879e3ced6f68a52637.tar.gz
updpkg: 7.2.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8b3f0aef5a7..230b60eedd3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sirius
pkgdesc = Domain specific library for electronic structure calculations
- pkgver = 7.2.4
- pkgrel = 2
+ pkgver = 7.2.6
+ pkgrel = 1
url = https://github.com/electronic-structure/SIRIUS
arch = x86_64
license = BSD
@@ -16,7 +16,7 @@ pkgbase = sirius
depends = hdf5
optdepends = magma: Linear algebra on GPU
options = !emptydirs
- source = sirius-7.2.4.tar.gz::https://github.com/electronic-structure/SIRIUS/archive/v7.2.4.tar.gz
- sha256sums = aeed0e83b80c3a79a9469e7f3fe10d80ad331795e38dbc3c49cb0308e2bd084d
+ source = sirius-7.2.6.tar.gz::https://github.com/electronic-structure/SIRIUS/archive/v7.2.6.tar.gz
+ sha256sums = e751fd46cdc7c481ab23b0839d3f27fb00b75dc61dc22a650c92fe8e35336e3a
pkgname = sirius
diff --git a/PKGBUILD b/PKGBUILD
index f616498397a9..9363a0b450b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=sirius
_PkgName=SIRIUS
-pkgver=7.2.4
-pkgrel=2
+pkgver=7.2.6
+pkgrel=1
pkgdesc="Domain specific library for electronic structure calculations"
arch=('x86_64')
license=('BSD')
@@ -12,14 +12,14 @@ depends=('libvdwxc' 'libxc' 'spglib' 'elpa' 'spfft' 'spla' 'gsl' 'hdf5')
makedepends=('cmake')
optdepends=('magma: Linear algebra on GPU')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('aeed0e83b80c3a79a9469e7f3fe10d80ad331795e38dbc3c49cb0308e2bd084d')
+sha256sums=('e751fd46cdc7c481ab23b0839d3f27fb00b75dc61dc22a650c92fe8e35336e3a')
options=(!emptydirs)
prepare() {
mkdir "$srcdir/build"
# Checking if nvcc is in PATH
- if [[ $( echo -n $( which nvcc) | tail -c 4 ) == nvcc ]]
+ if command -v nvcc &> /dev/null
then
export _ACC=ON
export LDFLAGS="$LDFLAGS -L/opt/cuda/lib64"
@@ -31,8 +31,6 @@ prepare() {
# Finding ELPA version
_ELPAVER=$( ls /usr/include | grep elpa | sed 's/elpa_openmp-//g' )
-
- sed -i 's/&vxc.at/vxc.at/' "$srcdir/$_PkgName-$pkgver/src/potential/xc.cpp"
}
build() {