summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2019-08-19 23:57:08 +0100
committerWorMzy Tykashi2019-08-19 23:57:08 +0100
commit3703374cf1863dc321ea071bf3b309500071d014 (patch)
tree2fd66866247dab0aed7a9afaad77f4776235f334
parent64687c762b7a3973ea0077bef5692c516e1bc65c (diff)
downloadaur-3703374cf1863dc321ea071bf3b309500071d014.tar.gz
Make pkgver increment, add utempter flag, syntax fixes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d4a3260de74..7b42b9796719 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tmux-git
pkgdesc = A terminal multiplexer
- pkgver = 2.6.r93.gad417f6e
+ pkgver = 7917_3.0.r22.g2db9a183
pkgrel = 1
url = https://github.com/tmux/tmux/wiki
arch = i686
@@ -9,7 +9,7 @@ pkgbase = tmux-git
makedepends = git
depends = ncurses
depends = libevent
- optdepends = libutempter: Record user sessions to utmp and wtmp files (add to depends array and rebuild to enable)
+ optdepends = libutempter: Record user sessions to utmp and wtmp files [add to depends array and rebuild to enable]
provides = tmux
conflicts = tmux
source = git+https://github.com/tmux/tmux.git
diff --git a/PKGBUILD b/PKGBUILD
index 36c78181241d..8c0c03104088 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=tmux-git
_gitname=tmux
-pkgver=2.6.r93.gad417f6e
+pkgver=7917_3.0.r22.g2db9a183
pkgrel=1
pkgdesc="A terminal multiplexer"
url="https://github.com/tmux/tmux/wiki"
@@ -14,8 +14,8 @@ arch=('i686' 'x86_64')
license=('BSD')
depends=('ncurses' 'libevent')
makedepends=('git')
-optdepends=('libutempter: Record user sessions to utmp and wtmp files (add to depends array and rebuild to enable)')
-#depends+=('libutempter')
+optdepends=('libutempter: Record user sessions to utmp and wtmp files [add to depends array and rebuild to enable]')
+#depends+=('libutempter') && _addconfigureflags="--enable-utempter"
provides=('tmux')
conflicts=('tmux')
source=('git+https://github.com/tmux/tmux.git'
@@ -24,27 +24,30 @@ md5sums=('SKIP'
'71601bc37fa44e4395580b321963018e')
pkgver() {
- cd $_gitname
- git describe --long | sed -e 's:\([^-]*-g\):r\1:' -e 's:-:.:g'
+ cd ${_gitname}
+ # Upstream reissues tags, which breaks 'describe --long'. Prefix with rev count to compensate.
+ printf "%s_%s" \
+ $(git rev-list --count HEAD) \
+ $(git describe --long) | sed -e 's:\([^-]*-g\):r\1:' -e 's:-:.:g'
}
prepare() {
- cd $_gitname
+ cd ${_gitname}
./autogen.sh
}
build() {
- cd $_gitname
- ./configure --prefix=/usr
+ cd ${_gitname}
+ ./configure --prefix=/usr ${_addconfigureflags}
make
}
package() {
- cd $_gitname
+ cd ${_gitname}
- make DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/tmux/LICENSE"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/tmux/LICENSE"
# install example config file
- install -Dm755 example_tmux.conf "$pkgdir/usr/share/tmux/example_tmux.conf"
+ install -Dm755 example_tmux.conf "${pkgdir}/usr/share/tmux/example_tmux.conf"
}