summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredy García2019-07-01 11:35:26 -0500
committerFredy García2019-07-01 11:35:26 -0500
commite1f0856b85aad7c3ff9bed8696f3c9316614da67 (patch)
tree81bc79ff85614fc926680fe1b489c24b9ba4b027
parent846095d85847d9af99789d0bbbd43b0cfa50ccd6 (diff)
downloadaur-e1f0856b85aad7c3ff9bed8696f3c9316614da67.tar.gz
Upgrading to version 0.32.0, changing go-pie by go to avoid issues in compilation (caused by CGO).
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--build_info.patch10
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc1b5d05b985..0a3be48c64c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = skaffold
pkgdesc = A command line tool that facilitates continuous development for Kubernetes applications
- pkgver = 0.31.0
+ pkgver = 0.32.0
pkgrel = 1
url = https://github.com/GoogleContainerTools/skaffold
arch = x86_64
license = Apache
- makedepends = go-pie
+ makedepends = go
depends = docker
depends = kubectl
optdepends = google-cloud-sdk: To use GKE
optdepends = minikube: To use Minikube
- source = skaffold-0.31.0.tar.gz::https://github.com/GoogleContainerTools/skaffold/archive/v0.31.0.tar.gz
+ source = skaffold-0.32.0.tar.gz::https://github.com/GoogleContainerTools/skaffold/archive/v0.32.0.tar.gz
source = build_info.patch
- sha256sums = 9434f8cf5e777d2f80976c5ba5616d97eabae1289b93c3013da6a482e30990d5
- sha256sums = 840df9da5528da50cb84cc7fc26265a5e48f96e6ecad86539b1c166455400652
+ sha256sums = d53305ac028c4562398029ebcc50baaaa43858a2247170abf07e4f9803d14b73
+ sha256sums = 6d5ce208be729d2451f524bbbe9899614d4ce65c6f167a073c0ef28bf4e1b109
pkgname = skaffold
diff --git a/PKGBUILD b/PKGBUILD
index 42a97dffb71b..4e91e51d1407 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Stefan Cocora <stefan dot cocora at gmail dot com>
pkgname=skaffold
-pkgver=0.31.0
+pkgver=0.32.0
pkgrel=1
pkgdesc="A command line tool that facilitates continuous development for Kubernetes applications"
arch=("x86_64")
url="https://github.com/GoogleContainerTools/${pkgname}"
license=("Apache")
depends=("docker" "kubectl")
-makedepends=("go-pie")
+makedepends=("go")
optdepends=(
"google-cloud-sdk: To use GKE"
"minikube: To use Minikube"
@@ -20,10 +20,10 @@ source=(
"build_info.patch"
)
sha256sums=(
- "9434f8cf5e777d2f80976c5ba5616d97eabae1289b93c3013da6a482e30990d5"
- "840df9da5528da50cb84cc7fc26265a5e48f96e6ecad86539b1c166455400652"
+ "d53305ac028c4562398029ebcc50baaaa43858a2247170abf07e4f9803d14b73"
+ "6d5ce208be729d2451f524bbbe9899614d4ce65c6f167a073c0ef28bf4e1b109"
)
-_commit="9935f9ecd68b50759d4180d7319e7fd43428fe3d"
+_commit="6ed7aad5e8a36052ee5f6079fc91368e362121f7"
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/build_info.patch b/build_info.patch
index b0b8aacec891..ab50d0dd7151 100644
--- a/build_info.patch
+++ b/build_info.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile b/Makefile
-index 476cbef..292355f 100644
+index 6634fdd..d58987c 100644
--- a/Makefile
+++ b/Makefile
@@ -32,7 +32,8 @@ SUPPORTED_PLATFORMS := linux-$(GOARCH) darwin-$(GOARCH) windows-$(GOARCH).exe
@@ -12,12 +12,12 @@ index 476cbef..292355f 100644
ifeq "$(strip $(VERSION))" ""
override VERSION = $(shell git describe --always --tags --dirty)
-@@ -46,7 +47,7 @@ GO_LDFLAGS += -extldflags \"${LDFLAGS}\"
- GO_LDFLAGS += -X $(VERSION_PACKAGE).version=$(VERSION)
+@@ -53,7 +54,7 @@ GO_BUILD_TAGS_windows := ""
+ GO_LDFLAGS = -X $(VERSION_PACKAGE).version=$(VERSION)
GO_LDFLAGS += -X $(VERSION_PACKAGE).buildDate=$(shell date +'%Y-%m-%dT%H:%M:%SZ')
GO_LDFLAGS += -X $(VERSION_PACKAGE).gitCommit=$(COMMIT)
-GO_LDFLAGS += -X $(VERSION_PACKAGE).gitTreeState=$(if $(shell git status --porcelain),dirty,clean)
+GO_LDFLAGS += -X $(VERSION_PACKAGE).gitTreeState=$(TREE_STATE)
- GO_LDFLAGS +="
- GO_FILES := $(shell find . -type f -name '*.go' -not -path "./vendor/*")
+ GO_LDFLAGS_windows =" $(GO_LDFLAGS) -extldflags \"$(LDFLAGS_windows)\""
+ GO_LDFLAGS_darwin =" $(GO_LDFLAGS) -extldflags \"$(LDFLAGS_darwin)\""