summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-22 18:50:10 +0800
committerzxp198210052024-04-22 18:50:10 +0800
commitc15c8245668c9eac47f7a1fcf702b4bc728a6642 (patch)
tree1aacdecb013151ff9b9a1b08cdd621ac46203214
parent5d8261df5d8d548d5bb2e105a39a88f8a469f9d6 (diff)
downloadaur-skm-bin.tar.gz
fix errors
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 33 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a938eed4b83..c2a93d8b7d5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = skm-bin
pkgdesc = A simple and powerful SSH keys manager
pkgver = 0.8.6
- pkgrel = 1
+ pkgrel = 2
url = https://timothyye.github.io/skm
+ arch = aarch64
+ arch = i686
arch = x86_64
license = MIT
- provides = skm
- source = skm-bin-0.8.6.tar.gz::https://github.com/TimothyYe/skm/releases/download/v0.8.6/skm_0.8.6_Linux_x86_64.tar.gz
- source = LICENSE::https://github.com/TimothyYe/skm/raw/master/LICENSE
- sha256sums = 5e1a4d476f513ae71de9cf12de5563b27a2e5fb74b39e062955195812f1ddaf5
- sha256sums = 9135a22d94f05de75cba7a299488e9155bb15634660e992138d2eb263e657004
+ provides = skm=0.8.6
+ conflicts = skm
+ source_aarch64 = skm-0.8.6-aarch64.tar.gz::https://github.com/TimothyYe/skm/releases/download/v0.8.6/skm_0.8.6_Linux_arm64.tar.gz
+ sha256sums_aarch64 = e1c91bf31f2cf50e403b271e57cb92aa0edfe45d14e693cc39cb89c43e00c09a
+ source_i686 = skm-0.8.6-i686.tar.gz::https://github.com/TimothyYe/skm/releases/download/v0.8.6/skm_0.8.6_Linux_i386.tar.gz
+ sha256sums_i686 = c28716920e95131fc1de98ba3ed3c28bb3dfb1fec8aef3e27bc956c64ad83315
+ source_x86_64 = skm-0.8.6-x86_64.tar.gz::https://github.com/TimothyYe/skm/releases/download/v0.8.6/skm_0.8.6_Linux_x86_64.tar.gz
+ sha256sums_x86_64 = 5e1a4d476f513ae71de9cf12de5563b27a2e5fb74b39e062955195812f1ddaf5
pkgname = skm-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0dd67da92d80..acf51e9ed23b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
-
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=skm-bin
pkgver=0.8.6
-pkgrel=1
+pkgrel=2
pkgdesc="A simple and powerful SSH keys manager"
-arch=('x86_64')
-url='https://timothyye.github.io/skm'
+arch=(
+ 'aarch64'
+ 'i686'
+ 'x86_64'
+)
+url="https://timothyye.github.io/skm"
+_ghurl="https://github.com/TimothyYe/skm"
license=('MIT')
-provides=("${pkgname%-bin}")
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/TimothyYe/skm/releases/download/v${pkgver}/skm_${pkgver}_Linux_x86_64.tar.gz"
- 'LICENSE::https://github.com/TimothyYe/skm/raw/master/LICENSE')
-sha256sums=('5e1a4d476f513ae71de9cf12de5563b27a2e5fb74b39e062955195812f1ddaf5'
- '9135a22d94f05de75cba7a299488e9155bb15634660e992138d2eb263e657004')
-
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=()
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar.gz::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_Linux_arm64.tar.gz")
+source_i686=("${pkgname%-bin}-${pkgver}-i686.tar.gz::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_Linux_i386.tar.gz")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar.gz::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_Linux_x86_64.tar.gz")
+sha256sums_aarch64=('e1c91bf31f2cf50e403b271e57cb92aa0edfe45d14e693cc39cb89c43e00c09a')
+sha256sums_i686=('c28716920e95131fc1de98ba3ed3c28bb3dfb1fec8aef3e27bc956c64ad83315')
+sha256sums_x86_64=('5e1a4d476f513ae71de9cf12de5563b27a2e5fb74b39e062955195812f1ddaf5')
package() {
- install -Dm755 "${srcdir}/${pkgname%-bin}" \
- "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/LICENSE" -t \
- "${pkgdir}/usr/share/licenses/${pkgname}"
-}
+ install -Dm755 "${srcdir}/${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file