summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoses Narrow2022-01-19 14:36:43 -0600
committerMoses Narrow2022-01-19 14:36:43 -0600
commita7101e8833d3c6e04f036eb799567206379f5d9b (patch)
tree19c21346c0588d514c41073c19bdd07d26c319a0
parent239e568e18ea678fad653d94ef538a03545c2224 (diff)
downloadaur-a7101e8833d3c6e04f036eb799567206379f5d9b.tar.gz
fix build failure caused by vendoring issues
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b509b68a14d..04d54b0f2ff0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = skycoin
pkgdesc = Skycoin Cryptocurrency Wallet. skycoin.com
pkgver = 0.27.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/skycoin/skycoin
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index aa17821dff36..5d812f9cf5c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,8 @@ _pkgname=${pkgname}
_githuborg=${_pkgname}
pkgdesc="Skycoin Cryptocurrency Wallet. skycoin.com"
pkgver=0.27.1
-#pkgver=0.27.1
-pkgrel=2
-#pkgrel=1
+pkgrel=3
+#pkgrel=3
arch=('x86_64' 'aarch64' 'armv8' 'armv7' 'armv7l' 'armv7h' 'armv6h' 'armhf' 'armel' 'arm')
_pkggopath="github.com/${_githuborg}/${_pkgname}"
url="https://${_pkggopath}"
@@ -34,7 +33,19 @@ build() {
export CC=musl-gcc
export CGO_ENABLED=1
_cmddir=${srcdir}/go/src/${_pkggopath}/cmd
-
+ cd ${srcdir}/go/src/${_pkggopath}
+ [[ ! -f go.mod ]] && go mod init
+ #go mod vendor
+ go mod tidy
+ ### manually go get the go deps
+ go get github.com/blang/semver
+ go get github.com/mgutz/ansi
+ go get github.com/sirupsen/logrus
+ go get github.com/spf13/viper
+ go get github.com/urfave/cli
+ go get golang.org/x/crypto/ssh/terminal
+ go get github.com/shopspring/decimal
+ ###
_buildbins address_gen
_buildbins cipher-testdata
_buildbins monitor-peers
@@ -54,7 +65,7 @@ _msg2 "building ${_binname} binary"
#SPEED UP TESTING OF BUILDS
if [[ ! -f ${GOBIN}/${_binname} ]] ; then
cd ${_cmddir}/${_binname}
- go build -trimpath --ldflags '-linkmode external -extldflags "-static" -buildid=' -o $GOBIN/ .
+ go build -mod=mod -trimpath --ldflags '-linkmode external -extldflags "-static" -buildid=' -o $GOBIN/ .
fi
}