summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Stenglein2023-03-04 08:44:00 -0500
committerMark Stenglein2023-03-04 08:44:00 -0500
commitd195190034aeb3d0645cb900127377785d361f55 (patch)
tree91cf194179a18906ddb4378609b299d9cb59532f
parent2c1aecb136772f81ed90555b9a3526fc6dca5385 (diff)
downloadaur-slides-git.tar.gz
0.9.0-2: Fix build after change to go cli
The go cli no longer accepts package args with the clean -testcache subcommand.
-rw-r--r--.SRCINFO2
-rw-r--r--CHANGELOG.md4
-rw-r--r--PKGBUILD5
3 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c51d1d12312..3d00f0400922 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = slides-git
pkgdesc = Terminal based presentation tool
- pkgver = 0.9.0.r0.g1620042
+ pkgver = 0.9.0.r13.g9e3e13e
pkgrel = 1
url = https://github.com/maaslalani/slides
changelog = CHANGELOG.md
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 71269f1faf3a..848dfa8f3553 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,9 @@
# Changelog
+## [0.9.0-2] - 2023-03-04
+
+- Fix build issue caused by change to go 1.20 cli. [#219](https://github.com/maaslalani/slides/issues/219)
+
## [0.9.0-1] - 2022-09-13
- Add ssh server functionality by [@ivantsepp](https://github.com/@ivantsepp) in [#150](https://github.com/maaslalani/slides/pull/150)
diff --git a/PKGBUILD b/PKGBUILD
index 11d8d8953325..6c9e459a30f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Stenglein <aur@markstenglein.com>
pkgname=slides-git
-pkgver=0.9.0.r0.g1620042
+pkgver=0.9.0.r13.g9e3e13e
pkgrel=1
pkgdesc='Terminal based presentation tool'
arch=('x86_64')
@@ -22,7 +22,8 @@ pkgver() {
prepare() {
cd ${pkgname%-git}
- go clean -testcache ./...
+ go clean -cache
+ go clean -testcache
}
build() {