summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJasper F2015-06-30 10:04:30 +0100
committerJasper F2015-06-30 10:04:30 +0100
commit129e6fbe0a46d4b342df2f49dd0f042c9c06dfbd (patch)
treedafbfe749b993d3d7210ec6a16d3a7accbdb5dca
downloadaur-slump.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--license.txt30
-rw-r--r--slump.install15
4 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3af17c9ada5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Fri May 15 08:30:12 UTC 2015
+pkgbase = slump
+ pkgdesc = A SLIGE-based random map generator for Freedoom
+ pkgver = 0.003.02
+ pkgrel = 3
+ url = http://www.samiam.org/slump.html
+ install = slump.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = http://www.samiam.org/slump/old/slump/slump-0.003.02.tar.bz2
+ source = license.txt
+ md5sums = 40069d684fe9a47a659dbc5d8182b37d
+ md5sums = 03dd7b8aeec8aea1cebe7d51d633e621
+
+pkgname = slump
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e07f77cd46a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jasper Follas follasjj@live.co.uk
+
+pkgname=slump
+pkgver=0.003.02
+pkgrel=3
+pkgdesc="A SLIGE-based random map generator for Freedoom"
+arch=('i686' 'x86_64')
+url="http://www.samiam.org/slump.html"
+license=('custom')
+depends=('glibc')
+install=slump.install
+source=('http://www.samiam.org/slump/old/slump/slump-0.003.02.tar.bz2'
+ 'license.txt')
+md5sums=('40069d684fe9a47a659dbc5d8182b37d'
+ '03dd7b8aeec8aea1cebe7d51d633e621')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # fix compiler flags
+ sed -i "s|-g ||g" Makefile
+
+ # add revenant to monster range and fix a naming bug
+ sed -e '9229 s|FALSE|TRUE|' \
+ -e 's|"slige|"slump|g' \
+ -i slump.c
+
+ # uncomment to add baron and hellknight (present in freedoom-svn only):
+ # sed -i -e '9158 s|FALSE|TRUE|' -e '9246 s|FALSE|TRUE|' slump.c
+
+ make FLAGS="${CFLAGS}" || return 1
+}
+
+package () {
+ install -m755 -D $srcdir/$pkgname-$pkgver/slump $pkgdir/usr/bin/slump
+ install -m644 -D $srcdir/license.txt $pkgdir/usr/share/licenses/custom/slump/license.txt
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..d259691f6797
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,30 @@
+Slump is relesed under the GPL with two optional requests added to the license:
+
+Copyright 2000 David Chess; Copyright 2005 Sam Trenholme
+
+Slump is free software; you can redistribute it and/or modify it under
+the terms of the GNU General Public License as published by the Free
+Software Foundation; either version 2, or (at your option) any later
+version.
+
+Slump is distributed in the hope that it will be useful, but WITHOUT ANY
+WARRANTY; without even the implied warranty of MERCHANTABILITY or
+FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+for more details.
+
+You should have received a copy of the GNU General Public License
+along with Slump; see the file GPL. If not, write to the Free
+Software Foundation, 59 Temple Place - Suite 330, Boston, MA
+02111-1307, USA.
+
+Additionally, while not required for redistribution of this program,
+the following requests are made when making a derived version of
+this program:
+
+* Slump's code is partly derived from the Doom map generator
+ called SLIGE, by David Chess. Please inform David Chess of
+ any derived version that you make. His email address is at
+ the domain "theogeny.com" with the name "chess" placed before
+ the at symbol.
+
+* Please do not call any derivative of this program SLIGE.
diff --git a/slump.install b/slump.install
new file mode 100644
index 000000000000..78fc37c4aab1
--- /dev/null
+++ b/slump.install
@@ -0,0 +1,15 @@
+post_install() {
+cat << EOF
+>>> The WADs generated by Slump need to be processed
+>>> by a node builder like BSP or ZenNode to be playable
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op "$@"