summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Picht2023-12-28 15:44:25 +0100
committerMichael Picht2023-12-28 15:44:25 +0100
commitfa0fca3256baa57f8aded3d223d81d37f0ad9670 (patch)
tree83e91e786d66bec00a4be4f526dc92997fa87680
downloadaur-smsync.tar.gz
initial package version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2873d85e0bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = smsync
+ pkgdesc = smsync (Smart Music Sync) keeps huge music collections in sync and is takes care of conversions between different file formats. It's an easy-to-use command line application for Linux
+ pkgver = 3.5.2
+ pkgrel = 1
+ url = https://gitlab.com/mipimipi/smsync/
+ arch = aarch64
+ arch = x86_64
+ license = GPL3
+ makedepends = bash
+ makedepends = git
+ makedepends = go
+ makedepends = make
+ depends = ffmpeg
+ conflicts = smsync-git
+ source = https://gitlab.com/mipimipi/smsync/-/archive/v3.5.2/smsync-v3.5.2.tar.gz
+ validpgpkeys = 11ECD6695134183B3E7AF1C2223AAA374A1D59CE
+ sha256sums = b47f6e387c3ec49187e8a06af31ccd1fd417b28e0dbd8da4cbf1630d52507826
+
+pkgname = smsync
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66ac039fa0f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Michael Picht <mipi@fsfe.org>
+
+_pkgorg=gitlab.com/mipimipi
+pkgname=smsync
+pkgver=3.5.2
+pkgrel=1
+pkgdesc="smsync (Smart Music Sync) keeps huge music collections in sync and is takes care of conversions between different file formats. It's an easy-to-use command line application for Linux"
+arch=(
+ aarch64
+ x86_64
+)
+url="https://$_pkgorg/$pkgname/"
+license=(GPL3)
+source=("https://${_pkgorg}/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+sha256sums=('b47f6e387c3ec49187e8a06af31ccd1fd417b28e0dbd8da4cbf1630d52507826')
+validpgpkeys=(11ECD6695134183B3E7AF1C2223AAA374A1D59CE) # Michael Picht <mipi@fsfe.org>
+depends=(ffmpeg)
+makedepends=(
+ bash
+ git
+ go
+ make
+)
+conflicts=(smsync-git)
+
+build() {
+ cd "${pkgname}-v${pkgver}" || return
+ make
+}
+
+package() {
+ cd "${pkgname}-v${pkgver}" || return
+ make DESTDIR="$pkgdir" install
+}