summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAryan Ghasemi2024-01-08 19:42:26 +0330
committerAryan Ghasemi2024-01-08 19:42:26 +0330
commitdeb9632a9e411b2d5a953d4b2236786c623c16cd (patch)
tree8cfc97a9616e35e413c91bc1e3bb69be36e94bd0
parentf8694a64bff8faa39b1fb3801981ef4deef5bcf4 (diff)
downloadaur-deb9632a9e411b2d5a953d4b2236786c623c16cd.tar.gz
.desktop exec path corrected
-rw-r--r--PKGBUILD5
-rw-r--r--smw-git.install37
2 files changed, 4 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 157b38b4f25b..4741f97c95dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,6 @@ pkgdesc='Super Mario multiplayer game.'
url='http://smwstuff.net/'
arch=('i686' 'x86_64')
license=('GPL')
-install=$pkgname.install
depends=('sdl_image' 'sdl_mixer' 'sdl' 'zlib')
makedepends=('git' 'cmake')
provides=('smw')
@@ -32,4 +31,8 @@ build() {
package() {
cd -- "$srcdir/supermariowar/build"
make install
+ sed -i 's/\(--datadir[[:space:]]\)[^[:space:]]*/\1\/var\/lib\/smw/' $pkgdir/usr/share/applications/supermariowar.desktop
+ sed -i 's/\(--datadir[[:space:]]\)[^[:space:]]*/\1\/var\/lib\/smw/' $pkgdir/usr/share/applications/supermariowar-leveleditor.desktop
+ sed -i 's/\(--datadir[[:space:]]\)[^[:space:]]*/\1\/var\/lib\/smw/' $pkgdir/usr/share/applications/supermariowar-worldeditor.desktop
+
}
diff --git a/smw-git.install b/smw-git.install
deleted file mode 100644
index 8de94458fab3..000000000000
--- a/smw-git.install
+++ /dev/null
@@ -1,37 +0,0 @@
-# This is a default template for a post-install scriptlet.
-# Uncomment only required functions and remove any functions
-# you don't need (and this header).
-
-## arg 1: the new package version
-#pre_install() {
- # do something here
-#}
-
-## arg 1: the new package version
-post_install() {
- sed -i 's/\(--datadir[[:space:]]\)[^[:space:]]*/\1\/var\/lib\/smw/' /usr/share/applications/supermariowar.desktop
- sed -i 's/\(--datadir[[:space:]]\)[^[:space:]]*/\1\/var\/lib\/smw/' /usr/share/applications/supermariowar-leveledit.desktop
- sed -i 's/\(--datadir[[:space:]]\)[^[:space:]]*/\1\/var\/lib\/smw/' /usr/share/applications/supermariowar-worldeditor.desktop
-}
-
-## arg 1: the new package version
-## arg 2: the old package version
-#pre_upgrade() {
- # do something here
-#}
-
-## arg 1: the new package version
-## arg 2: the old package version
-#post_upgrade() {
- # do something here
-#}
-
-## arg 1: the old package version
-#pre_remove() {
- # do something here
-#}
-
-## arg 1: the old package version
-#post_remove() {
- # do something here
-#}