summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciek Borzecki2018-02-26 09:11:42 +0100
committerMaciek Borzecki2018-02-26 09:32:54 +0100
commitbf3913b5acca75ede0f309a9b7ae065883c43a54 (patch)
treeebe759e3865692de009e13287b711e7ee20bffcf
parente54948d302f23dae25fed6631881538848134302 (diff)
downloadaur-bf3913b5acca75ede0f309a9b7ae065883c43a54.tar.gz
snapd: bump base version, drop /snap symlink, sync with snapd recipe
Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
-rw-r--r--snapd.install40
3 files changed, 3 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e7f3629a994..db67dd099a7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = snapd-git
pkgdesc = Service and tools for management of snap packages.
- pkgver = 2.31.r470.g8fd74f718
+ pkgver = 2.31.1.r608.g0da606958
pkgrel = 1
url = https://github.com/snapcore/snapd
install = snapd.install
diff --git a/PKGBUILD b/PKGBUILD
index b2dd6383c555..cd955f3862bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=snapd-git
pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd')
optdepends=('bash-completion: bash completion support')
-pkgver=2.31.r470.g8fd74f718
+pkgver=2.31.1.r608.g0da606958
pkgrel=1
arch=('x86_64')
url="https://github.com/snapcore/snapd"
@@ -56,7 +56,6 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- # Generate version
./mkversion.sh $pkgver-$pkgrel
# Use get-deps.sh provided by upstream to fetch go dependencies using the
@@ -84,7 +83,6 @@ build() {
SNAPD_ENVIRONMENT_FILE=/etc/default/snapd
cd cmd
- # Sync actual parameters with cmd/autogen.sh
autoreconf -i -f
./configure \
--prefix=/usr \
@@ -150,9 +148,6 @@ package_snapd-git() {
install -Dm755 "$GOPATH/bin/snap-update-ns" "$pkgdir/usr/lib/snapd/snap-update-ns"
install -Dm755 "$GOPATH/bin/snap-exec" "$pkgdir/usr/lib/snapd/snap-exec"
- # Symlink /var/lib/snapd/snap to /snap so that --classic snaps work
- ln -s var/lib/snapd/snap "$pkgdir/snap"
-
# pre-create directories
install -dm755 "$pkgdir/var/lib/snapd/snap"
install -dm755 "$pkgdir/var/cache/snapd"
@@ -175,6 +170,7 @@ package_snapd-git() {
make -C cmd install DESTDIR="$pkgdir/"
# Install man file
+ mkdir -p "$pkgdir/usr/share/man/man1"
"$GOPATH/bin/snap" help --man > "$pkgdir/usr/share/man/man1/snap.1"
# Install the "info" data file with snapd version
diff --git a/snapd.install b/snapd.install
index 9dc6585b338a..b93f37a61b25 100644
--- a/snapd.install
+++ b/snapd.install
@@ -1,45 +1,5 @@
-## arg 1: the new package version
-post_install() {
- echo
- echo 'To use snapd start/enable the snapd.socket'
- echo
- echo 'If you want your apps to be automatically updated'
- echo 'from the store start/enable the snapd.refresh.timer'
- echo
- echo 'NOTE: Desktop entries show up after logging in again'
- echo ' or rebooting after snapd installation'
- echo
- echo 'For more informations, see https://wiki.archlinux.org/index.php/Snapd'
-}
-
-_stop_services() {
- /usr/bin/systemctl stop \
- snapd.service \
- snapd.socket \
- snapd.refresh.timer \
- snapd.refresh.service > /dev/null 2>&1
-}
-
pre_remove() {
- _stop_services
-
/usr/lib/snapd/snap-mgmt --purge || :
}
-pre_upgrade() {
- _stop_services
-}
-
-post_upgrade() {
- /usr/bin/systemctl daemon-reload > /dev/null 2>&1 || :
-
- # restore the services after an upgrade
- if /usr/bin/systemctl -q is-enabled snapd.socket > /dev/null 2>&1; then
- /usr/bin/systemctl start snapd.socket > /dev/null 2>&1 || :
- fi
- if systemctl -q is-enabled snapd.refresh.timer > /dev/null 2>&1; then
- systemctl start snapd.refresh.timer > /dev/null 2>&1 || :
- fi
-}
-
# vim:set ts=2 sw=2 et: