summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-09-10 13:32:29 -0400
committerAndrew Sun2019-09-10 13:32:29 -0400
commit1b1c266ec7b6d8c0355057ce40ddb1a630961cc6 (patch)
tree00ddae626bc87e226a467f25c7ce109a240af571
parenta98185187b51ad432b707aab305541b8876addae (diff)
downloadaur-sni-qt.tar.gz
sni-qt: update to 0.2.7
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb46c12861ce..a4907831042b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = sni-qt
pkgdesc = Qt4 plugin which turns all QSystemTrayIcon into StatusNotifierItems (appindicators)
- pkgver = 0.2.6
- pkgrel = 5
+ pkgver = 0.2.7+17.04.20170112
+ pkgrel = 1
url = https://launchpad.net/sni-qt
arch = x86_64
license = LGPL3
makedepends = cmake
depends = libdbusmenu-qt4
backup = etc/sni-qt.conf
- source = https://launchpad.net/sni-qt/trunk/0.2.6/+download/sni-qt-0.2.6.tar.bz2
- source = https://launchpad.net/sni-qt/trunk/0.2.6/+download/sni-qt-0.2.6.tar.bz2.asc
+ source = https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/sni-qt/0.2.7+17.04.20170112-0ubuntu1/sni-qt_0.2.7+17.04.20170112.orig.tar.gz
source = sni-qt.conf
- validpgpkeys = 45C43F82329D77F384214CCABEED35A5EEE34473
- sha512sums = aa4cffeb3a5a70d65bd5ff42dcdd1c8efd107ade32a104b9a91696aecfb39a7a15d151f7491030ac0d7df796f2c7e4e6c3c0b7e32ee07a7cdc949da757147621
- sha512sums = SKIP
+ sha512sums = 2636a0b7eb66e5e46e160dfccd93c47ce8accafcb2e46503b4b472735cd97a478c4ce727d5d6451ef2f72b9652296c6da1483ea2b22150d32be340ac223b1f80
sha512sums = 41b838b851c88d9dae9d598515c16d1bd8b526af341bd026df8b4d68b07670a05fe33577af73a81c71744da7934507c88fc121a494b53dbbfe3bf24fe9694382
pkgname = sni-qt
diff --git a/PKGBUILD b/PKGBUILD
index 7620293ce13d..fb44ad82d640 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Maintainer: Andrew Sun <adsun701 at gmail dot com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Alcasa Mz <alcasa.mz@gmail.com>
pkgname=sni-qt
-pkgver=0.2.6
-pkgrel=5
+pkgver=0.2.7+17.04.20170112
+pkgrel=1
pkgdesc='Qt4 plugin which turns all QSystemTrayIcon into StatusNotifierItems (appindicators)'
arch=('x86_64')
url='https://launchpad.net/sni-qt'
@@ -11,30 +12,28 @@ license=('LGPL3')
depends=('libdbusmenu-qt4')
makedepends=('cmake')
backup=('etc/sni-qt.conf')
-source=("https://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.bz2"{,.asc}
+source=("https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/${pkgname}/${pkgver}-0ubuntu1/${pkgname}_${pkgver}.orig.tar.gz"
'sni-qt.conf')
-sha512sums=('aa4cffeb3a5a70d65bd5ff42dcdd1c8efd107ade32a104b9a91696aecfb39a7a15d151f7491030ac0d7df796f2c7e4e6c3c0b7e32ee07a7cdc949da757147621'
- 'SKIP'
+sha512sums=('2636a0b7eb66e5e46e160dfccd93c47ce8accafcb2e46503b4b472735cd97a478c4ce727d5d6451ef2f72b9652296c6da1483ea2b22150d32be340ac223b1f80'
'41b838b851c88d9dae9d598515c16d1bd8b526af341bd026df8b4d68b07670a05fe33577af73a81c71744da7934507c88fc121a494b53dbbfe3bf24fe9694382')
-validpgpkeys=('45C43F82329D77F384214CCABEED35A5EEE34473') # Aurelien Gateau <agateau@kde.org>
prepare() {
- mkdir build
+ mkdir -p ${srcdir}/build
# Disable building tests
- sed -i '/tests/ d' ${pkgname}-${pkgver}/CMakeLists.txt
+ sed -i '/tests/ d' ${srcdir}/CMakeLists.txt
}
build() {
- cd build
- cmake ../${pkgname}-${pkgver} \
+ cd ${srcdir}/build
+ cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release
make
}
package() {
- cd build
+ cd ${srcdir}/build
make DESTDIR="${pkgdir}" install
# Install config file for apps that need "Activate" action