summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Guihal2015-06-09 21:52:08 +0200
committerDamien Guihal2015-06-09 21:55:36 +0200
commit8652030a23f3b63665a4935e41989ae254666f88 (patch)
tree6bc70c0ac21496ec8638e6fdf6c4bcf58d3bc2e6
downloadaur-8652030a23f3b63665a4935e41989ae254666f88.tar.gz
initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD56
-rwxr-xr-xsoapui76
-rw-r--r--soapui.desktop10
4 files changed, 166 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1874ba483209
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = soapui
+ pkgdesc = A graphical Java program for inspecting, invoking, monitoring, simulating/mocking and functional/load/compliance/surveillance testing of REST/WADL and SOAP/WSDL-based Web Services over HTTP.
+ pkgver = 5.1.3
+ pkgrel = 2
+ url = http://www.soapui.org/
+ arch = i686
+ arch = x86_64
+ license = LGPLv2
+ depends = java-runtime
+ source = http://downloads.sourceforge.net/project/soapui/soapui/5.1.3/SoapUI-5.1.3-linux-bin.tar.gz
+ source = http://freeapps.co.uk.s3.amazonaws.com/images/thumbnails/soapui.png
+ source = soapui.desktop
+ source = soapui
+ md5sums = 69497d409c2e6038f3c684741ffe3566
+ md5sums = 3cc08aca62edb502fc53013edf69f640
+ md5sums = f0e2fa73dd9a7c271e38c179b4e284a3
+ md5sums = 46e71776148c5f043ead3b2648e6f575
+ sha1sums = 345e0ab1c78da00c82aef0cbd5f782b6b78a0fe6
+ sha1sums = 9f12e2f0db63083a3fa4e5b6fdfd10c8dfd038c0
+ sha1sums = 4ced7d28c3c5880db600bf4769fdb1a3dc3a6fce
+ sha1sums = 9c5648b9453935f4a5dd633ccd8ea32541fabb95
+
+pkgname = soapui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d3ce216f9cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Damien Guihal <dguihal@gmail.com>
+pkgname=soapui
+pkgver=5.1.3
+pkgrel=2
+pkgdesc="A graphical Java program for inspecting, invoking, monitoring, simulating/mocking and functional/load/compliance/surveillance testing of REST/WADL and SOAP/WSDL-based Web Services over HTTP."
+arch=('i686' 'x86_64')
+url="http://www.soapui.org/"
+license=('LGPLv2')
+groups=()
+depends=('java-runtime')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/SoapUI-$pkgver-linux-bin.tar.gz"
+ "http://freeapps.co.uk.s3.amazonaws.com/images/thumbnails/$pkgname.png"
+ "$pkgname.desktop"
+ "$pkgname")
+noextract=()
+#generate with 'makepkg -g'
+md5sums=('69497d409c2e6038f3c684741ffe3566'
+ '3cc08aca62edb502fc53013edf69f640'
+ 'f0e2fa73dd9a7c271e38c179b4e284a3'
+ '46e71776148c5f043ead3b2648e6f575')
+sha1sums=('345e0ab1c78da00c82aef0cbd5f782b6b78a0fe6'
+ '9f12e2f0db63083a3fa4e5b6fdfd10c8dfd038c0'
+ '4ced7d28c3c5880db600bf4769fdb1a3dc3a6fce'
+ '9c5648b9453935f4a5dd633ccd8ea32541fabb95')
+
+build() {
+ cd ${srcdir}/SoapUI-$pkgver
+
+ #Correction du bug jxplorer
+ sed -i -e 's/^java/${JAVA_HOME}\/bin\/java/' bin/soapui.sh
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/soapui
+ mkdir -p ${pkgdir}/usr/bin
+ cd ${srcdir}/SoapUI-$pkgver
+ cp -R * ${pkgdir}/usr/share/soapui
+
+ cd ${srcdir}
+ install $pkgname.desktop -m 0644 -D ${pkgdir}/usr/share/applications/$pkgname.desktop
+ install $pkgname.png -m 0644 -D ${pkgdir}/usr/share/icons/hicolor/48x48/apps/$pkgname.png
+ install $pkgname -m 0755 -D ${pkgdir}/usr/bin/soapui
+ chmod 0755 ${pkgdir}/usr/share/soapui/bin/soapui.sh
+
+ cd ${pkgdir}/usr/share/soapui
+ ln -sf bin/starter-page.html .
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/soapui b/soapui
new file mode 100755
index 000000000000..3d1226348d39
--- /dev/null
+++ b/soapui
@@ -0,0 +1,76 @@
+#!/bin/sh
+### ====================================================================== ###
+## ##
+## SoapUI Bootstrap Script ##
+## ##
+### ====================================================================== ###
+
+### $Id$ ###
+
+DIRNAME=`dirname $0`
+
+# OS specific support (must be 'true' or 'false').
+cygwin=false;
+darwin=false;
+case "`uname`" in
+ CYGWIN*)
+ cygwin=true
+ ;;
+ Darwin*)
+ darwin=true
+ ;;
+esac
+
+# Setup SOAPUI_BASE
+if [ "x$SOAPUI_HOME" = "x" ];
+then
+ SOAPUI_HOME=$HOME
+fi
+export SOAPUI_HOME
+
+if [ "x$SOAPUI_BASE" = "x" ];
+then
+ # get the full path (without any relative bits)
+ SOAPUI_BASE=/usr/share/soapui
+fi
+export SOAPUI_BASE
+
+SOAPUI_CLASSPATH=$SOAPUI_BASE/bin/soapui-5.1.2.jar:$SOAPUI_BASE/lib/*
+
+export SOAPUI_CLASSPATH
+
+JAVA_OPTS="-Dawt.useSystemAAFontSettings=on -Xms128m -Xmx1024m -Dsoapui.properties=soapui.properties -Dsoapui.home=$SOAPUI_HOME -splash:soapui-splash.png"
+
+if $darwin
+then
+ JAVA_OPTS="$JAVA_OPTS -Dswing.crossplatformlaf=apple.laf.AquaLookAndFeel -Dapple.eawt.quitStrategy=CLOSE_ALL_WINDOWS"
+fi
+
+if [ $SOAPUI_BASE != "" ]
+then
+ JAVA_OPTS="$JAVA_OPTS -Dsoapui.ext.libraries=$SOAPUI_BASE/bin/ext"
+ JAVA_OPTS="$JAVA_OPTS -Dsoapui.ext.listeners=$SOAPUI_BASE/bin/listeners"
+ JAVA_OPTS="$JAVA_OPTS -Dsoapui.ext.actions=$SOAPUI_BASE/bin/actions"
+ JAVA_OPTS="$JAVA_OPTS -Djava.library.path=$SOAPUI_BASE/bin"
+ JAVA_OPTS="$JAVA_OPTS -Dwsi.dir=$SOAPUI_BASE/wsi-test-tools"
+#uncomment to disable browser component
+# JAVA_OPTS="$JAVA_OPTS -Dsoapui.jxbrowser.disable=true"
+fi
+
+export JAVA_OPTS
+
+# For Cygwin, switch paths to Windows format before running java
+if [ $cygwin = "true" ]
+then
+ SOAPUI_BASE=`cygpath --path --dos "$SOAPUI_BASE"`
+ SOAPUI_CLASSPATH=`cygpath --path --dos "$SOAPUI_CLASSPATH"`
+fi
+
+cd $DIRNAME
+echo ================================
+echo =
+echo = SOAPUI_BASE = $SOAPUI_BASE
+echo =
+echo ================================
+
+${JAVA_HOME}/bin/java $JAVA_OPTS -cp $SOAPUI_CLASSPATH com.eviware.soapui.SoapUI "$@"
diff --git a/soapui.desktop b/soapui.desktop
new file mode 100644
index 000000000000..70f46d87c572
--- /dev/null
+++ b/soapui.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Exec=soapui %u
+Icon=soapui
+Terminal=false
+Name=soapUI
+GenericName=Grafical interface for testing Web Services
+GenericName[fr]=interface graphique de test pour les web services
+GenericName[es]=Interfaz gráfico para probar Servicios Web
+Categories=Development;IDE;