summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Guihal2018-05-08 23:09:54 +0200
committerDamien Guihal2018-05-08 23:09:54 +0200
commitc3f728305631ff610e28e907ef2bb4fbe51241cf (patch)
treef9878b4bacc5e161c75026303f4d1a0c4324e6c7
parent81a773905f0381a9b3582b5f9a76cd5378096919 (diff)
downloadaur-c3f728305631ff610e28e907ef2bb4fbe51241cf.tar.gz
Change soapui workdir and logdir
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rwxr-xr-xsoapui39
3 files changed, 20 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7913f5f47c1..c16b28d0bfae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = soapui
pkgdesc = A graphical Java program for inspecting, invoking, monitoring, simulating/mocking and functional/load/compliance/surveillance testing of REST/WADL and SOAP/WSDL-based Web Services over HTTP.
pkgver = 5.4.0
- pkgrel = 4
+ pkgrel = 5
url = http://www.soapui.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e84c6d53dfb3..2acca2813736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Do not forget SRCINFO : makepkg --printsrcinfo > .SRCINFO
pkgname=soapui
pkgver=5.4.0
-pkgrel=4
+pkgrel=5
pkgdesc="A graphical Java program for inspecting, invoking, monitoring, simulating/mocking and functional/load/compliance/surveillance testing of REST/WADL and SOAP/WSDL-based Web Services over HTTP."
arch=('i686' 'x86_64')
url="http://www.soapui.org/"
@@ -18,11 +18,11 @@ source=("https://s3.amazonaws.com/downloads.eviware/soapuios/$pkgver/SoapUI-$pkg
md5sums=('37a9cc3df46c1e3e1a2be264a8749291'
'3cc08aca62edb502fc53013edf69f640'
'f0e2fa73dd9a7c271e38c179b4e284a3'
- '0f92cc9882a7a6165a642c3a67c9961b')
+ 'dbc1cc1ad0920cb85aa11af780651bf9')
sha1sums=('1218f2b43fe0fd7048cc6cd8d298c233fc159e49'
'9f12e2f0db63083a3fa4e5b6fdfd10c8dfd038c0'
'4ced7d28c3c5880db600bf4769fdb1a3dc3a6fce'
- '290b3c12781d2242c9dbb9a760a8713f533cbd2c')
+ '4ca542b6b6d85cb86ba2f3785debd80c07a66050')
build() {
cd ${srcdir}/SoapUI-$pkgver-EB
diff --git a/soapui b/soapui
index cfaccc0d0224..ebf9b8beb535 100755
--- a/soapui
+++ b/soapui
@@ -21,40 +21,33 @@ case "`uname`" in
;;
esac
-# Setup SOAPUI_BASE
-if [ "x$SOAPUI_HOME" = "x" ];
-then
- SOAPUI_HOME=$HOME
-fi
+# Setup SOAPUI_HOME
+SOAPUI_HOME=/usr/share/soapui
export SOAPUI_HOME
-if [ "x$SOAPUI_BASE" = "x" ];
-then
- # get the full path (without any relative bits)
- SOAPUI_BASE=/usr/share/soapui
-fi
-export SOAPUI_BASE
-
-SOAPUI_CLASSPATH=$SOAPUI_BASE/bin/soapui-#SOAPUIVER#-EB.jar:$SOAPUI_BASE/lib/*
+SOAPUI_CLASSPATH=$SOAPUI_HOME/bin/soapui-#SOAPUIVER#-EB.jar:$SOAPUI_HOME/lib/*
export SOAPUI_CLASSPATH
-JAVA_OPTS="-Dawt.useSystemAAFontSettings=on -Xms128m -Xmx1024m -Dsoapui.properties=soapui.properties -Dsoapui.home=$SOAPUI_HOME -splash:soapui-splash.png"
+JAVA_OPTS="-Xms128m -Xmx1024m -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -Dsoapui.properties=soapui.properties -Dsoapui.home=$SOAPUI_HOME/bin -splash:SoapUI-Spashscreen.png"
+JAVA_OPTS="$JAVA_OPTS -Dawt.useSystemAAFontSettings=on -Duser.home=$HOME/.soapuios/ -Dsoapui.logroot=$HOME/.soapuios/"
+JFXRTPATH=`java -cp $SOAPUI_CLASSPATH com.eviware.soapui.tools.JfxrtLocator`
+SOAPUI_CLASSPATH=$JFXRTPATH:$SOAPUI_CLASSPATH
if $darwin
then
JAVA_OPTS="$JAVA_OPTS -Dswing.crossplatformlaf=apple.laf.AquaLookAndFeel -Dapple.eawt.quitStrategy=CLOSE_ALL_WINDOWS"
fi
-if [ $SOAPUI_BASE != "" ]
+if [ $SOAPUI_HOME != "" ]
then
- JAVA_OPTS="$JAVA_OPTS -Dsoapui.ext.libraries=$SOAPUI_BASE/bin/ext"
- JAVA_OPTS="$JAVA_OPTS -Dsoapui.ext.listeners=$SOAPUI_BASE/bin/listeners"
- JAVA_OPTS="$JAVA_OPTS -Dsoapui.ext.actions=$SOAPUI_BASE/bin/actions"
- JAVA_OPTS="$JAVA_OPTS -Djava.library.path=$SOAPUI_BASE/bin"
- JAVA_OPTS="$JAVA_OPTS -Dwsi.dir=$SOAPUI_BASE/wsi-test-tools"
+ JAVA_OPTS="$JAVA_OPTS -Dsoapui.ext.libraries=$SOAPUI_HOME/bin/ext"
+ JAVA_OPTS="$JAVA_OPTS -Dsoapui.ext.listeners=$SOAPUI_HOME/bin/listeners"
+ JAVA_OPTS="$JAVA_OPTS -Dsoapui.ext.actions=$SOAPUI_HOME/bin/actions"
+ JAVA_OPTS="$JAVA_OPTS -Djava.library.path=$SOAPUI_HOME/bin"
+ JAVA_OPTS="$JAVA_OPTS -Dwsi.dir=$SOAPUI_HOME/wsi-test-tools"
#uncomment to disable browser component
-# JAVA_OPTS="$JAVA_OPTS -Dsoapui.jxbrowser.disable=true"
+# JAVA_OPTS="$JAVA_OPTS -Dsoapui.browser.disabled=true"
fi
export JAVA_OPTS
@@ -62,14 +55,14 @@ export JAVA_OPTS
# For Cygwin, switch paths to Windows format before running java
if [ $cygwin = "true" ]
then
- SOAPUI_BASE=`cygpath --path --dos "$SOAPUI_BASE"`
+ SOAPUI_HOME=`cygpath --path --dos "$SOAPUI_HOME"`
SOAPUI_CLASSPATH=`cygpath --path --dos "$SOAPUI_CLASSPATH"`
fi
cd $DIRNAME
echo ================================
echo =
-echo = SOAPUI_BASE = $SOAPUI_BASE
+echo = SOAPUI_HOME = $SOAPUI_HOME
echo =
echo ================================