summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-09-29 14:50:40 +0200
committerXiretza2020-09-29 14:50:40 +0200
commitdad97cc6d343bb178e739c14854d3f5967afc8ea (patch)
tree6b4843637bc9556521a4fa574858be33a3742ddd
parent740678a648fe6954f0542f06a00b8319fc1bf362 (diff)
downloadaur-dad97cc6d343bb178e739c14854d3f5967afc8ea.tar.gz
Update to 1.6.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD51
-rw-r--r--qpainter-include.patch25
3 files changed, 57 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5422d438fbd1..eea283e1c2d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = solarus-quest-editor
pkgdesc = A graphical user interface to create and modify quests for the Solarus engine.
- pkgver = 1.6.0
- pkgrel = 2
- url = http://www.solarus-games.org/
+ pkgver = 1.6.4
+ pkgrel = 1
+ url = https://www.solarus-games.org/
arch = i686
arch = x86_64
license = GPL
@@ -13,8 +13,10 @@ pkgbase = solarus-quest-editor
depends = qt5-base
depends = qt5-tools
depends = glm
- source = https://gitlab.com/solarus-games/solarus-quest-editor/-/archive/v1.6.0.tar.gz
- md5sums = 405466fc52f7d22cb271bdf6e4193b16
+ source = https://gitlab.com/solarus-games/solarus-quest-editor/-/archive/v1.6.4/solarus-quest-editor-v1.6.4.tar.gz
+ source = qpainter-include.patch
+ sha256sums = 741f44c4e04316b67c9ec3fba636526c1013d61b32a23343f8a655e8a50f9ac7
+ sha256sums = 02eb7a944b2161d471a1f14230da9f292cd29a8ac6427d331011b749efe7de47
pkgname = solarus-quest-editor
diff --git a/PKGBUILD b/PKGBUILD
index a5642f4c72cb..8cf219f67901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,41 @@
-# Maintainer: Maxs <max dot van dot den dot branden @t gmail dot com>
-pkgname="solarus-quest-editor"
-pkgver="1.6.0"
-pkgrel="2"
-epoch=
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+# Contributor: Maxs <max dot van dot den dot branden @t gmail dot com>
+
+pkgname=solarus-quest-editor
+pkgver=1.6.4
+pkgrel=1
pkgdesc="A graphical user interface to create and modify quests for the Solarus engine."
arch=("i686" "x86_64")
-url="http://www.solarus-games.org/"
+url="https://www.solarus-games.org/"
license=("GPL" "custom")
-groups=()
depends=("solarus" "qt5-base" "qt5-tools" "glm")
makedepends=("cmake" "zip")
checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("https://gitlab.com/solarus-games/$pkgname/-/archive/v$pkgver.tar.gz")
-noextract=()
-md5sums=("405466fc52f7d22cb271bdf6e4193b16")
-commit=("cfbcf8a3bf22968c0fef1b431edcf2d19be7c1e3")
+source=("https://gitlab.com/solarus-games/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+ "qpainter-include.patch")
+sha256sums=('741f44c4e04316b67c9ec3fba636526c1013d61b32a23343f8a655e8a50f9ac7'
+ '02eb7a944b2161d471a1f14230da9f292cd29a8ac6427d331011b749efe7de47')
+
+prepare() {
+ cd "$srcdir/$pkgname-v$pkgver"
+
+ patch -p1 < "$srcdir/qpainter-include.patch"
+}
build() {
- cd "$srcdir/$pkgname-v$pkgver-$commit"
+ mkdir build
+ cd build
- cmake -D CMAKE_BUILD_TYPE=Release -D CMAKE_INSTALL_PREFIX="/usr" .
+ cmake \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_INSTALL_PREFIX="/usr" \
+ "../$pkgname-v$pkgver"
make
}
package() {
- cd "$srcdir/$pkgname-v$pkgver-$commit"
+ cd "$srcdir/build"
make DESTDIR="${pkgdir}/" install
- install -Dm644 "license.txt" "$pkgdir/usr/share/licences/$pkgname/license.txt"
- install -Dm644 "images/logo/sqe-logo.png" "$pkgdir/usr/share/pixmaps/sqe-logo.png"
- install -Dm644 "resources/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname-v$pkgver/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
}
-
diff --git a/qpainter-include.patch b/qpainter-include.patch
new file mode 100644
index 000000000000..05f91b101cdd
--- /dev/null
+++ b/qpainter-include.patch
@@ -0,0 +1,25 @@
+From 81d5c7f1602cf355684d70a5e3449fefccfc44b8 Mon Sep 17 00:00:00 2001
+From: Hugo Hromic <hhromic@gmail.com>
+Date: Mon, 1 Jun 2020 18:45:16 +0100
+Subject: [PATCH] Add missing include directive for QPainterPath
+
+* Not implicit anymore since Qt 5.15
+---
+ src/entities/jumper.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/entities/jumper.cpp b/src/entities/jumper.cpp
+index 5d4b31e0..edd38fa9 100644
+--- a/src/entities/jumper.cpp
++++ b/src/entities/jumper.cpp
+@@ -17,6 +17,7 @@
+ #include "entities/jumper.h"
+ #include "map_model.h"
+ #include <QPainter>
++#include <QPainterPath>
+
+ namespace SolarusEditor {
+
+--
+GitLab
+