summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2021-04-09 23:19:34 +0200
committerXiretza2021-04-09 23:19:34 +0200
commite947fe315144ca6c28c3cea6f009a08d4c1f3c5e (patch)
tree4b20c14231be723d7eaf4406266a70c293e8de03
parentdad97cc6d343bb178e739c14854d3f5967afc8ea (diff)
downloadaur-e947fe315144ca6c28c3cea6f009a08d4c1f3c5e.tar.gz
Update to 1.6.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--qpainter-include.patch25
3 files changed, 6 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eea283e1c2d7..bdd18e38fe0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = solarus-quest-editor
pkgdesc = A graphical user interface to create and modify quests for the Solarus engine.
- pkgver = 1.6.4
+ pkgver = 1.6.5
pkgrel = 1
url = https://www.solarus-games.org/
arch = i686
@@ -13,10 +13,8 @@ pkgbase = solarus-quest-editor
depends = qt5-base
depends = qt5-tools
depends = glm
- source = https://gitlab.com/solarus-games/solarus-quest-editor/-/archive/v1.6.4/solarus-quest-editor-v1.6.4.tar.gz
- source = qpainter-include.patch
- sha256sums = 741f44c4e04316b67c9ec3fba636526c1013d61b32a23343f8a655e8a50f9ac7
- sha256sums = 02eb7a944b2161d471a1f14230da9f292cd29a8ac6427d331011b749efe7de47
+ source = https://gitlab.com/solarus-games/solarus-quest-editor/-/archive/v1.6.5/solarus-quest-editor-v1.6.5.tar.gz
+ sha256sums = c2e292bf34696968dfb0fe56fb21af8566b7a4001b84535c39e30ae7a3d9bb6e
pkgname = solarus-quest-editor
diff --git a/PKGBUILD b/PKGBUILD
index 8cf219f67901..769bfb33b176 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Maxs <max dot van dot den dot branden @t gmail dot com>
pkgname=solarus-quest-editor
-pkgver=1.6.4
+pkgver=1.6.5
pkgrel=1
pkgdesc="A graphical user interface to create and modify quests for the Solarus engine."
arch=("i686" "x86_64")
@@ -11,15 +11,12 @@ license=("GPL" "custom")
depends=("solarus" "qt5-base" "qt5-tools" "glm")
makedepends=("cmake" "zip")
checkdepends=()
-source=("https://gitlab.com/solarus-games/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
- "qpainter-include.patch")
-sha256sums=('741f44c4e04316b67c9ec3fba636526c1013d61b32a23343f8a655e8a50f9ac7'
- '02eb7a944b2161d471a1f14230da9f292cd29a8ac6427d331011b749efe7de47')
+source=("https://gitlab.com/solarus-games/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+sha256sums=('c2e292bf34696968dfb0fe56fb21af8566b7a4001b84535c39e30ae7a3d9bb6e')
prepare() {
cd "$srcdir/$pkgname-v$pkgver"
- patch -p1 < "$srcdir/qpainter-include.patch"
}
build() {
diff --git a/qpainter-include.patch b/qpainter-include.patch
deleted file mode 100644
index 05f91b101cdd..000000000000
--- a/qpainter-include.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 81d5c7f1602cf355684d70a5e3449fefccfc44b8 Mon Sep 17 00:00:00 2001
-From: Hugo Hromic <hhromic@gmail.com>
-Date: Mon, 1 Jun 2020 18:45:16 +0100
-Subject: [PATCH] Add missing include directive for QPainterPath
-
-* Not implicit anymore since Qt 5.15
----
- src/entities/jumper.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/entities/jumper.cpp b/src/entities/jumper.cpp
-index 5d4b31e0..edd38fa9 100644
---- a/src/entities/jumper.cpp
-+++ b/src/entities/jumper.cpp
-@@ -17,6 +17,7 @@
- #include "entities/jumper.h"
- #include "map_model.h"
- #include <QPainter>
-+#include <QPainterPath>
-
- namespace SolarusEditor {
-
---
-GitLab
-