summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaravanan palanisamy2020-11-27 21:10:43 +0400
committersaravanan palanisamy2020-11-27 21:10:43 +0400
commitf7dbae919c7593a6c52c53126fa163a1ff8f0c9d (patch)
tree7c0372d976456599e7d5902a5c021f151276f944
downloadaur-solokey-full-disk-encryption.tar.gz
add solokey-luks package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec4fba303fea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = solokey-full-disk-encryption
+ pkgdesc = Use SoloKey to unlock a LUKS partition
+ pkgver = r39.ee0359d
+ pkgrel = 1
+ url = https://github.com/saravanan30erd/solokey-full-disk-encryption
+ arch = any
+ license = Apache
+ depends = fido2luks
+ depends = cryptsetup
+ backup = etc/skfde.conf
+ source = git+https://github.com/saravanan30erd/solokey-full-disk-encryption.git
+ sha256sums = SKIP
+
+pkgname = solokey-full-disk-encryption
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62ef78b3ba02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=solokey-full-disk-encryption
+pkgver=r39.ee0359d
+pkgrel=1
+pkgdesc='Use SoloKey to unlock a LUKS partition'
+arch=('any')
+url='https://github.com/saravanan30erd/solokey-full-disk-encryption'
+license=('Apache')
+depends=('fido2luks' 'cryptsetup')
+makedepends=('git')
+backup=('etc/skfde.conf')
+source=('git+https://github.com/saravanan30erd/solokey-full-disk-encryption.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}