summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2018-07-12 09:54:33 -0700
committerDonald Webster2018-07-12 09:54:33 -0700
commitc28080ee77c49946ece2327299b5434cd28c24e2 (patch)
tree1393b4e28e1c40231a7bc140d85475976a92739a
parentdb984f43cc86ad036c0caef4b2628bc054888ef2 (diff)
downloadaur-c28080ee77c49946ece2327299b5434cd28c24e2.tar.gz
Switch to hard coded version, sha256sum and https.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 14 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8a549808fdc..f60c8ef128e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sonarr-develop
pkgdesc = PVR for newsgroup users. Formerly known as NZBDrone, with added torrent support.
- pkgver = 2.0.0.4163
+ pkgver = 2.0.0.5239
pkgrel = 1
url = http://www.sonarr.tv
install = sonarr.install
@@ -13,22 +13,16 @@ pkgbase = sonarr-develop
optdepends = nzbget: an NZB downloader
optdepends = transmission: a torrent downloader
optdepends = deluge: a torrent downloader
- provides = nzbdrone
- provides = nzbdrone-torrents
provides = sonarr
- conflicts = nzbdrone
- conflicts = nzbdrone-torrents
conflicts = sonarr
- replaces = nzbdrone
- replaces = nzbdrone-torrents
- source = http://download.sonarr.tv/v2/develop/mono/NzbDrone.develop.tar.gz
+ source = https://download.sonarr.tv/v2/develop/mono/NzbDrone.develop.2.0.0.5239.mono.tar.gz
source = sonarr.service
source = sonarr.sysusers
source = sonarr.install
- md5sums = SKIP
- md5sums = 4489e2fd01d8958acbb994ce21063fb6
- md5sums = 9a334e656488c989309297fbb40c2520
- md5sums = 99387b40dd89f726319b67e1d1e480b5
+ sha256sums = 15206c3ba421c7db282de82562084a473666e09447d2ccd7fa28557e03860548
+ sha256sums = ffcd28b3779aae0edf093956dfbd3239bea0b32561da75ab1d198de92db197c5
+ sha256sums = cc3c69f719fa64335f4c5b41b2588f1ec56865fb2202f5919d3668b50b8f398e
+ sha256sums = ce45de775371d7b05f8f1313679b8a94e093fb2fae8ea2cb7558428c1d51d9af
pkgname = sonarr-develop
diff --git a/PKGBUILD b/PKGBUILD
index a26742ea1b23..8aebc8da58ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Justin Dray <justin@dray.be>
# Maintainer: Daniel Egeberg <daniel.egeberg@gmail.com>
pkgname="sonarr-develop"
-pkgver=2.0.0.4163
+pkgver=2.0.0.5239
pkgrel=1
pkgdesc="PVR for newsgroup users. Formerly known as NZBDrone, with added torrent support."
arch=(any)
@@ -13,23 +13,17 @@ optdepends=('sabnzbd: an NZB downloader'
'transmission: a torrent downloader'
'deluge: a torrent downloader')
install='sonarr.install'
-provides=('nzbdrone' 'nzbdrone-torrents' 'sonarr')
-conflicts=('nzbdrone' 'nzbdrone-torrents' 'sonarr')
-replaces=('nzbdrone' 'nzbdrone-torrents')
-changelog=
-source=("http://download.sonarr.tv/v2/develop/mono/NzbDrone.develop.tar.gz"
+provides=('sonarr')
+conflicts=('sonarr')
+source=("https://download.sonarr.tv/v2/develop/mono/NzbDrone.develop.${pkgver}.mono.tar.gz"
"sonarr.service"
"sonarr.sysusers"
"sonarr.install")
noextract=()
-md5sums=('SKIP'
- '4489e2fd01d8958acbb994ce21063fb6'
- '9a334e656488c989309297fbb40c2520'
- '99387b40dd89f726319b67e1d1e480b5')
-
-pkgver() {
- curl -Ss http://download.sonarr.tv/v2/develop/mono/ | awk 'match($0, "NzbDrone.develop.(2.[0-9.]*)\\.mono", ary) {print ary[1]}' | tail -n1
-}
+sha256sums=('15206c3ba421c7db282de82562084a473666e09447d2ccd7fa28557e03860548'
+ 'ffcd28b3779aae0edf093956dfbd3239bea0b32561da75ab1d198de92db197c5'
+ 'cc3c69f719fa64335f4c5b41b2588f1ec56865fb2202f5919d3668b50b8f398e'
+ 'ce45de775371d7b05f8f1313679b8a94e093fb2fae8ea2cb7558428c1d51d9af')
package() {
cd "$srcdir"
@@ -42,9 +36,6 @@ package() {
install -dm 755 "${pkgdir}/usr/lib/sonarr"
cp -dpr --no-preserve=ownership "${srcdir}/NzbDrone/"* "${pkgdir}/usr/lib/sonarr"
- msg2 "Install executable into /usr/bin"
- install -Dm755 "${srcdir}/sonarr.sh" "${pkgdir}/usr/bin/sonarr"
-
msg2 "Install sonarr.service"
install -Dm 644 "${srcdir}/sonarr.service" "${pkgdir}/usr/lib/systemd/system/sonarr.service"
}