summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-11-05 02:39:56 +0100
committerFabioLolix2017-11-05 02:39:56 +0100
commitc19f4a4601e4886a622e182e000b9b8cea59d316 (patch)
treeefaf1951081735e53d88354e36b3eaa8647334c6
downloadaur-sonerezh.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--example_nginx_vhost.conf21
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1e21431d75c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = sonerezh
+ pkgdesc = A self-hosted, web-based application for stream your music, everywhere
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = https://www.sonerezh.bzh
+ arch = any
+ license = GPL3
+ depends = php
+ depends = php-gd
+ optdepends = mariadb: Database backend
+ optdepends = libav-no-libs: Music transcoding
+ provides = sonerezh
+ conflicts = sonerezh-git
+ conflicts = sonerezh-devel-git
+ options = !strip
+ source = https://github.com/Sonerezh/sonerezh/archive/1.1.3.tar.gz
+ source = example_nginx_vhost.conf
+ md5sums = d572cf39336bdfb02e4366c572ee8c82
+ md5sums = 955712ddb7884cc7343e67109155ed1e
+
+pkgname = sonerezh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9aa6399c2631
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Charles Wise <charles at charlesbwise dot com>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=sonerezh
+pkgver=1.1.3
+pkgrel=1
+pkgdesc='A self-hosted, web-based application for stream your music, everywhere'
+arch=('any')
+url='https://www.sonerezh.bzh'
+license=('GPL3')
+depends=('php' 'php-gd')
+optdepends=('mariadb: Database backend'
+ 'libav-no-libs: Music transcoding')
+options=('!strip')
+source=("https://github.com/Sonerezh/sonerezh/archive/${pkgver}.tar.gz"
+ "example_nginx_vhost.conf")
+md5sums=('d572cf39336bdfb02e4366c572ee8c82'
+ '955712ddb7884cc7343e67109155ed1e')
+provides=('sonerezh')
+conflicts=('sonerezh-git' 'sonerezh-devel-git')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -d "${pkgdir}/usr/share/webapps/sonerezh"
+ cp -r * "${pkgdir}/usr/share/webapps/sonerezh/"
+
+ install -d "${pkgdir}/etc/webapps/sonerezh"
+
+ install -d "${pkgdir}/usr/share/doc/sonerezh"
+ install -Dm644 "${srcdir}/example_nginx_vhost.conf" "${pkgdir}/usr/share/doc/sonerezh/"
+}
diff --git a/example_nginx_vhost.conf b/example_nginx_vhost.conf
new file mode 100644
index 000000000000..ece7b1eab0f2
--- /dev/null
+++ b/example_nginx_vhost.conf
@@ -0,0 +1,21 @@
+server {
+ server_name sonerezh.localhost;
+ access_log /var/log/nginx/sonerezh.access.log;
+ error_log /var/log/nginx/sonerezsh.error.log;
+
+ root /usr/share/webapps/sonerezh/app/webroot;
+ index index.php;
+
+ location / {
+ try_files $uri $uri/ /index.php?$args;
+ expires 14d;
+ add_header Cache-Control 'public';
+ }
+
+ location ~ \.php$ {
+ fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
+ fastcgi_index index.php;
+ fastcgi_pass unix:/run/php-fpm/php-fpm.sock;
+ include fastcgi_params;
+ }
+}