summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Kuther2015-07-29 11:17:58 +0200
committerThomas Kuther2015-07-29 11:17:58 +0200
commit7461735883bccc662756821048b70c1f2f686d81 (patch)
treef3df4fa95071b6a6c79fb9e17d34e296de472429
downloadaur-sony-gpsassist-update-git.tar.gz
initial checkin to aur4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18b0ccf30c0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sony-gpsassist-update-git
+ pkgdesc = Auto-update GPS_A data for Sony Alpha cameras
+ pkgver = 10.e0a5c18
+ pkgrel = 1
+ url = https://github.com/gimpel/sony-gpsassist-update
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ backup = etc/sony-gpsassist-update.cfg
+ source = sony-gpsassist-update::git+https://github.com/gimpel/sony-gpsassist-update.git
+ md5sums = SKIP
+
+pkgname = sony-gpsassist-update-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c808cd52b6dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tom Kuther tom@kuther.net>
+pkgname=sony-gpsassist-update-git
+_gitname=sony-gpsassist-update
+pkgver=10.e0a5c18
+pkgrel=1
+pkgdesc="Auto-update GPS_A data for Sony Alpha cameras"
+arch=('i686' 'x86_64')
+url="https://github.com/gimpel/sony-gpsassist-update"
+license=('GPL')
+makedepends=('git')
+backup=('etc/sony-gpsassist-update.cfg')
+source=("${_gitname}::git+https://github.com/gimpel/sony-gpsassist-update.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_gitname"
+ DESTDIR="$pkgdir/" ./install.sh
+}
+
+# vim:set ts=2 sw=2 et: